OSPF Hello and Dead Interval

OSPF uses hello packets and two timers to check if a neighbor is still alive or not:

  • Hello interval: this defines how often we send the hello packet.
  • Dead interval:  this defines how long we should wait for hello packets before we declare the neighbor dead.

The hello and dead interval values can be different depending on the OSPF network type. On Ethernet interfaces you will see a 10 second hello interval and a 40 second dead interval.

Let’s take a look at an example so we can see this in action. Here’s the topology I will use:

OSPF R1 SW R2

We’ll use two routers with a switch in between.

Configuration

Let’s enable OSPF:

R1 & R2#
(config)#router ospf 1
(config-router)#network 192.168.12.0 0.0.0.255 area 0

Let’s take a look at the default hello and dead interval:

R1#show ip ospf interface FastEthernet 0/0 | include intervals
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

The hello and dead interval can be different for each interface. Above you can see that the hello interval is 10 seconds and the dead interval is 40 seconds. Let’s try if this is true:

R1(config)#interface FastEthernet 0/0
R1(config-if)#shutdown 

After shutting the interface on R1 you will see the following message:

R1#
Aug 30 17:57:05.519: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.12.2 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached

R1 will know that R2 is unreachable since its interface went down. Now take a look at R2:

R2#
Aug 30 17:57:40.863: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.12.1 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Dead timer expired

R2 is telling us that the dead timer has expired. This took a bit longer. The interface on R1 went down at 17:57:05 and R2’s dead timer expired at 17:57:40…that’s close to 40 seconds.

Let’s activate the interface again:

R1(config)#interface FastEthernet 0/0
R1(config-if)#no shutdown

40 seconds is a long time…R2 will keep sending traffic to R1 while the dead interval is expiring. To speed up this process we can play with the timers. Here’s an example:

R1 & R2
(config)#interface FastEthernet 0/0
(config-if)#ip ospf hello-interval 1 
(config-if)#ip ospf dead-interval 3

You can use these two commands to change the hello and dead interval. We’ll send a hello packet every second and the dead interval is 3 seconds. Let’s verify this:

R1#show ip ospf interface FastEthernet 0/0 | include intervals
  Timer intervals configured, Hello 1, Dead 3, Wait 3, Retransmit 5

Reducing the dead interval from 40 to 3 seconds is a big improvement but we can do even better:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You've Ever Spent on Your Cisco Career!
  • Full Access to our 660 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

510 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Tags:


Forum Replies

  1. Hi,

    what are the disadvantages of using bfd.
    also it would be helpful if you post an article on troubleshooting bfd.

  2. BFD does not work in GNS3. I was using 7200 with IOS 15.x. Checking on forums the consensus is a GNS3 bug. Does anyone have a workaround for this?

    Hostname R1
    !
    interface FastEthernet0/0
     ip address 10.0.0.9 255.255.255.252
     ip ospf 10 area 0
     duplex full
     bfd interval 500 min_rx 500 multiplier 3
    !
    router ospf 10
     router-id 10.0.0.1
     bfd all-interfaces
    

    -

    Hostname R2
    !
    interface FastEthernet0/0
     ip address 10.0.0.10 255.255.255.252
     ip ospf 10 area 0
     duplex full
     bfd interval 500 min_rx 500 multiplier 3
    !
    router ospf 10
     router-id 10.0.0.1
     bfd all-interfaces
    
    ... Continue reading in our forum

  3. Hi @tadeosho70,

    With echo mode, this is no problem. The packets you send are echoed back to you. For example, take a look at this output:

    R1(config)#interface FastEthernet 0/0
    R1(config-if)#bfd interval 300 min_rx 300 multiplier 3 
    
    R2(config)#interface FastEthernet 0/0
    R2(config-if)#bfd interval 300 min_rx 600 multiplier 3 
    

    The min_rx is set to 300 on R1 and 600 on R2. Here’s the output of R1 showing the 600 ms of R2:

    R1#show bfd neighbors details 
    
    NeighAddr                         LD/RD    RH/RS     State     Int
    192.168.12.2                       1/1     U
    ... Continue reading in our forum

39 more replies! Ask a question or join the discussion by visiting our Community Forum