How to configure OSPF Totally NSSA Area

OSPF has different special area types, I covered these before:

Now it’s time to demonstrate the totally NSSA area. Here is the topology we will use:

ospf stub area

And here’s the configuration. We will turn OSPF Area 1 into a stub area:

R1(config)#router ospf 1
R1(config-router)#network 192.168.12.0 0.0.0.255 area 0
R1(config-router)#redistribute connected subnets
R2(config)#router ospf 1
R2(config-router)#area 1 stub
R2(config-router)#network 192.168.12.0 0.0.0.255 area 0 
R2(config-router)#network 192.168.23.0 0.0.0.255 area 1
R3(config)#router ospf 1
R3(config-router)#area 1 stub
R3(config-router)#network 192.168.23.0 0.0.0.255 area 1

Let’s see what the routing table of R3 looks like:

R3#show ip route ospf 
O IA 192.168.12.0/24 [110/2] via 192.168.23.2, 00:00:42, FastEthernet0/0
O*IA 0.0.0.0/0 [110/2] via 192.168.23.2, 00:00:42, FastEthernet0/0

When we look at R3 you’ll see network 192.168.12.0 /24 as inter-area (LSA Type 3) and 1.1.1.0 /24 as external type 2 (LSA Type 5). First we’ll create a loopback interface on R3 and redistribute it into OSPF to show you the NSSA area.

R3(config)#interface loopback 0
R3(config-if)#ip address 3.3.3.3 255.255.255.0
R3(config-if)#exit
R3(config)#router ospf 1
R3(config-router)#redistribute connected subnets

I’ll add a new loopback interface and try to redistribute it into OSPF on R3, here’s what you’ll see:

R3# %OSPF-4-ASBR_WITHOUT_VALID_AREA: Router is currently an ASBR while having only one area which is a stub area

The stub and totally stub area block LSA Type 5 so it’s impossible to have an ASBR within these areas. First I’ll change area 1 into an NSSA to allow this ASBR:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You've Ever Spent on Your Cisco Career!
  • Full Access to our 657 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

524 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Tags: ,


Forum Replies

  1. Hi Rene !

    When you configured the area 1 nssa no-summary you have not configured the same statement in router Susan. Why not ? Its not also necessary? or i am misunderstanding and you have to configured in the ASBR only ?

    You said that we have to configured the area 1 nssa-summary in all the area. So i have that doubt.

    THANKS IN ADVANCE !!

  2. Hi Ieltxu,

    Good question. You have to configure “no-summary” only on the ABR since that’s the router that will inject the default route(s) into the area. No need to do it on all routers in the (totally) NSSA area.

    Rene

  3. Rene lets say i have 3 routers on Area 1, to have a totally NSSA, i only need to configure area 1 stub nssa on 3 routers? then the abr is area 1 stub nssa no-summary?
    so in short, the ASBR must be configured “area 1 nssa” while the ABR is “area 1 nssa no-summary” to achieve the Totally NSSA?

  4. Hi John,

    That’s right, within the NSSA area all routers only need “area x nssa”. Only the ABR requires “area x nssa no-summary”.

    Rene

  5. Hi Ajith,

    That’s right, it’s the ABR that will block the LSAs from entering the stub or nssa area so that’s the only router where you have to add “no-summary”.

    Rene

1 more reply! Ask a question or join the discussion by visiting our Community Forum