EIGRP Add Path Support

The EIGRP Add Path Support is a feature that allows the hub in a DMVPN topology to advertise multiple best paths to its spoke routers. This feature is needed if you have two or more spoke routers that advertise the same subnet. The hub router will learn about the subnet from both spoke routers so it can use ECMP (Equal Cost Multipath) with both spoke routers. EIGRP however, will only advertise one path to other spoke routers. Without this feature, you can’t use ECMP between spoke routers and when one of your spoke routers fail, EIGRP has to re-converge.

The Add Path Support feature is best explained with an example. I’ll show you a “before” and “after” scenario so you can see the difference.

EIGRP Add Path Support is only available in EIGRP named mode.

Configuration

Here is the topology I will use:

eigrp add path support topology

Above we have a hub router and four spoke routers. These routers are connected to each other using their GigabitEthernet0/1 interfaces and the 192.168.123.0/24 subnet. The tunnel interfaces for DMVPN use the 172.16.123.0/24 subnet.

The EIGRP Add Path Support is a feature that allows the hub in a DMVPN topology to advertise multiple best paths to its spoke routers. This feature is needed if you have two or more spoke routers that advertise the same subnet. The hub router will learn about the subnet from both spoke routers so it


Spoke1 and spoke2 are connected to the 192.168.12.0/24 subnet, spoke3 and spoke4 to the 192.168.34.0/24 subnet.

This network is configured to use DMVPN phase 2 and EIGRP has been pre-configured to advertise the GigabitEthernet0/2 interfaces of the spoke routers.

Configurations

Want to take a look for yourself? Here you will find the startup configuration of each device.

Hub

hostname Hub
!
ip cef
!
interface Tunnel0
 ip address 172.16.123.254 255.255.255.0
 ip nhrp authentication DMVPN
 ip nhrp map multicast dynamic
 ip nhrp network-id 1
 ip nhrp redirect
 tunnel source GigabitEthernet0/1
 tunnel mode gre multipoint
!
interface GigabitEthernet0/1
 ip address 192.168.123.254 255.255.255.0
!
router eigrp ADDPATH
 !
 address-family ipv4 unicast autonomous-system 1234
  !
  af-interface Tunnel0
   no next-hop-self
   no split-horizon
  exit-af-interface
  !
  topology base
  exit-af-topology
  network 172.16.123.0 0.0.0.255
 exit-address-family
!
end

Spoke1

hostname Spoke1
!
ip cef
!
interface Tunnel0
 ip address 172.16.123.1 255.255.255.0
 ip nhrp authentication DMVPN
 ip nhrp map 172.16.123.254 192.168.123.254
 ip nhrp map multicast 192.168.123.254
 ip nhrp network-id 1
 ip nhrp nhs 172.16.123.254
 tunnel source GigabitEthernet0/1
 tunnel mode gre multipoint
!
interface GigabitEthernet0/1
 ip address 192.168.123.1 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 192.168.12.1 255.255.255.0
!
router eigrp ADDPATH
 !
 address-family ipv4 unicast autonomous-system 1234
  !
  topology base
  exit-af-topology
  network 172.16.123.0 0.0.0.255
  network 192.168.12.0
 exit-address-family
!
end

Spoke2

hostname Spoke2
!
ip cef
!
interface Tunnel0
 ip address 172.16.123.2 255.255.255.0
 ip nhrp authentication DMVPN
 ip nhrp map 172.16.123.254 192.168.123.254
 ip nhrp map multicast 192.168.123.254
 ip nhrp network-id 1
 ip nhrp nhs 172.16.123.254
 tunnel source GigabitEthernet0/1
 tunnel mode gre multipoint
!
interface GigabitEthernet0/1
 ip address 192.168.123.2 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 192.168.12.2 255.255.255.0
!
router eigrp ADDPATH
 !
 address-family ipv4 unicast autonomous-system 1234
  !
  topology base
  exit-af-topology
  network 172.16.123.0 0.0.0.255
  network 192.168.12.0
 exit-address-family
!
end

Spoke3

hostname Spoke3
!
ip cef
!
interface Tunnel0
 ip address 172.16.123.3 255.255.255.0
 ip nhrp authentication DMVPN
 ip nhrp map 172.16.123.254 192.168.123.254
 ip nhrp map multicast 192.168.123.254
 ip nhrp network-id 1
 ip nhrp nhs 172.16.123.254
 tunnel source GigabitEthernet0/1
 tunnel mode gre multipoint
!
interface GigabitEthernet0/1
 ip address 192.168.123.3 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 192.168.34.3 255.255.255.0
!
router eigrp ADDPATH
 !
 address-family ipv4 unicast autonomous-system 1234
  !
  topology base
  exit-af-topology
  network 172.16.123.0 0.0.0.255
  network 192.168.34.0
 exit-address-family
!
end

Spoke4

hostname Spoke4
!
ip cef
!
interface Tunnel0
 ip address 172.16.123.4 255.255.255.0
 ip nhrp authentication DMVPN
 ip nhrp map 172.16.123.254 192.168.123.254
 ip nhrp map multicast 192.168.123.254
 ip nhrp network-id 1
 ip nhrp nhs 172.16.123.254
 tunnel source GigabitEthernet0/1
 tunnel mode gre multipoint
!
interface GigabitEthernet0/1
 ip address 192.168.123.4 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 192.168.34.4 255.255.255.0
!
router eigrp ADDPATH
 !
 address-family ipv4 unicast autonomous-system 1234
  !
  topology base
  exit-af-topology
  network 172.16.123.0 0.0.0.255
  network 192.168.34.0
 exit-address-family
!
end

Let’s take a look at the routing tables of all routers:

Hub#show ip route eigrp

D     192.168.12.0/24 [90/76805120] via 172.16.123.2, 00:03:24, Tunnel0
                      [90/76805120] via 172.16.123.1, 00:03:24, Tunnel0
D     192.168.34.0/24 [90/76805120] via 172.16.123.4, 00:03:24, Tunnel0
                      [90/76805120] via 172.16.123.3, 00:03:24, Tunnel0

The output of the hub’s routing table is looking good. The hub can load balance to both 192.168.12.0/24 and 192.168.34.0/24. Let’s take a look at the spoke routers:

Spoke1#show ip route eigrp

D     192.168.34.0/24 [90/102405120] via 172.16.123.3, 00:03:24, Tunnel0
Spoke2#show ip route eigrp

D     192.168.34.0/24 [90/102405120] via 172.16.123.3, 00:03:25, Tunnel0
Spoke3#show ip route eigrp

D     192.168.12.0/24 [90/102405120] via 172.16.123.1, 00:03:24, Tunnel0
Spoke4#show ip route eigrp

D     192.168.12.0/24 [90/102405120] via 172.16.123.1, 00:03:25, Tunnel0

The spoke routers each have only a single entry. This is because the hub won’t advertise two routes for a single network. We have reachability, but it’s a shame that for example, spoke1 can only reach 192.168.34.0/24 by going through spoke3. It would be nice if it could also use spoke4. Also, if spoke3 fails, EIGRP has to re-converge.

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You've Ever Spent on Your Cisco Career!
  • Full Access to our 660 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

503 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Forum Replies

  1. Hi William,

    Under topology base you will find commands that have to do with the EIGRP topology table. Stuff like redistribution, filtering, etc. Here’s an overview of all commands:

    R1(config-router)#router eigrp TEST                               
    R1(config-router)#address-family ipv4 unicast autonomous-system 1 
    R1(config-router-af)#topology base                                  
    R1(config-router-af-topology)#?
    Address Family Topology configuration commands:
      auto-summary         Enable automatic network number summarization
      cts                  EIGRP Trust
    ... Continue reading in our forum

  2. Hi Lagapides ,

    Thanks …Well understand this explanation…

  3. Hello Vinod

    The main differences between named and classic modes are the way in which they are implemented (globally for named while both globally and in interface mode for classic) as well as the addition of a sixth K value for the metric.

    On the back end, that is, concerning the way that the routers interpret and operate in EIGRP, very little has changed. So a named mode EIGRP router can communicate with a classic EIGRP router. Since you configure the AS number under the EIGRP name configuration, if the AS is the same, they will communicate.

    Now the only re

    ... Continue reading in our forum

  4. Hello Network

    EIGRP named mode supports what is known as the Wide Metrics feature. This feature supports 64-bit metric calculations as opposed to EIGRP classic mode that use 32-bit calculations. This results in varying metric values between the two.

    Wide metrics was introduced in order to accommodate high-bandwidth interfaces and Ethernet channels. The increase in available speeds has resulted in incorrect or inconsistent routing behavior with the classic EIGRP routing metrics. The lowest delay that can be configured for an interface is 10 microseconds. As a

    ... Continue reading in our forum

  5. Hi Rene and staff

    i just look at EIGRP named to configure a lab in another lesson
    So i explore the commands of the configuration modes; in the labs i did, i only used the topology mode base

    //cdn-forum.networklessons.com/uploads/default/original/2X/8/87a71f721e6599edd2950c22c1f353b41646ecbf.jpeg

    I tried to test (just for fun) the command with EIGRP that i suppose to set Multi-Topology Routing

    //cdn-forum.networklessons.com/uploads/default/original/2X/c/caea5318bdc479a90f5e217502cbdd6967531566.jpeg

    As you see, IOS answer “VIDEO does not exist”
    Could you give me

    ... Continue reading in our forum

21 more replies! Ask a question or join the discussion by visiting our Community Forum