Any Transport Over MPLS (AToM)

Any Transport over MPLS (AToM) will transport layer 2 frames over an MPLS (Multiprotocol Label Switching) network. This will allow service providers to connect layer 2 networks of customers transparently by using their MPLS backbone. AToM can transport the following:

  • ATM AAL5
  • ATM Cell Relay
  • Ethernet
  • Frame Relay
  • PPP
  • HDLC

I will give you an example of how to configure AToM to transport Ethernet over the MPLS backbone. We will use the following topology to do this:

MPLS Atom Ethernet

Above, you see a small MPLS backbone that consists of the PE1, P, and PE2 routers. This ISP only has one customer that has an HQ and Branch. The customer wants to have the HQ and Branch router to be in the same layer 2 segment.

Configuration

First, we will enable OSPF to advertise the loopback interfaces. These will be used as the router ID for MPLS LDP:

PE1(config)#router ospf 1
PE1(config-router)#network 192.168.12.0 0.0.0.255 area 0
PE1(config-router)#network 1.1.1.1 0.0.0.0 area 0
P(config)#router ospf 1
P(config-router)#network 192.168.12.0 0.0.0.255 area 0
P(config-router)#network 192.168.23.0 0.0.0.255 area 0
P(config-router)#network 2.2.2.2 0.0.0.0 area 0
PE2(config)#router ospf 1
PE2(config-router)#network 192.168.23.0 0.0.0.255 area 0
PE2(config-router)#network 3.3.3.3 0.0.0.0 area 0

Now we will enable MPLS LDP on the interfaces connecting the PE1, P, and PE2 routers:

PE1(config)#interface fastEthernet 0/1
PE1(config-if)#mpls ip
P(config)#interface fastEthernet 0/0
P(config-if)#mpls ip

P(config)#interface fastEthernet 0/1
P(config-if)#mpls ip 
PE2(config)#interface fastEthernet 0/0
PE2(config-if)#mpls ip

Just to be sure let’s verify that we have LDP neighbors:

P#show mpls ldp neighbor | include Peer
    Peer LDP Ident: 1.1.1.1:0; Local LDP Ident 2.2.2.2:0
    Peer LDP Ident: 3.3.3.3:0; Local LDP Ident 2.2.2.2:0

That seems to be the case! Now we can configure AToM so that the HQ and Branch routers are able to reach each other:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You’ve Ever Spent on Your Cisco Career!
  • Full Access to our 786 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

1592 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Tags:


Forum Replies

  1. Thank you, Rene, for what you do. I like very much the way you simplify complicated things. Keep doing great stuff !!!

  2. Rene! its a great walkthrough tutorial but little help required. which ios version to use? 12.4 does not support “xconnect 1.1.1.1 13 encapsulation mpls” command. waiting for your reply

  3. Hi Babar,

    I think the problem is not the 12.4 IOS version but the platform you are using. I’m not 100% sure but I believe in GNS3 you can only do it on the 7200 router, not the 3600/3700 series. I haven’t checked it on my 1841 and 2811 routers but I can take a look if you want.

    Rene

  4. Thanks Rene,
    I have changed the ios to 12.4.9T with the platform 7200. Still its not working…
    Any ideas??

60 more replies! Ask a question or join the discussion by visiting our Community Forum