BGP Auto-Summary

In a previous lesson I explained how the BGP network command works. When we enable auto-summary for BGP, the way the network command works changes slightly.

Normally when you advertise a network in BGP you have to type in the exact network and subnet mask that you want to advertise or it won’t be placed in the BGP table.

With auto-summary enabled, you can advertise a classful network and you don’t have to add the mask parameter. BGP will automatically advertise the classful network if you have the classful network or a subnet of this network in your routing table. Let me give you an example to explain what I’m talking about. I’ll use these two routers:

BGP R1 R2 AS1 AS2 Topology

These routers are configured for eBGP, there’s a loopback interface on R1 with network 1.1.1.1 /32. Here’s the configuration:

R1#show run | section bgp
router bgp 1
 bgp log-neighbor-changes
 neighbor 192.168.12.2 remote-as 2
R2#show run | section bgp
router bgp 2
 bgp log-neighbor-changes
 neighbor 192.168.12.1 remote-as 1

The configuration is straight-forward, we only configured eBGP, no networks have been advertised and auto-summary is disabled. Let’s see if we can advertise classful network 1.0.0.0/8:

R1(config)#router bgp 1
R1(config-router)#network 1.0.0.0

Note that I didn’t specify a subnet mask with the mask parameter. Take a look at the BGP table now:

R1#show ip bgp 1.0.0.0
% Network not in table

As expected there is nothing in the BGP table since we require the exact network and subnet mask. Let’s enable auto-summary now so you can see the difference:

R1(config)#router bgp 1
R1(config-router)#auto-summary

After enabling auto-summary things will change. Take a look at the BGP table of R1:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You've Ever Spent on Your Cisco Career!
  • Full Access to our 660 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

510 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Forum Replies

  1. Hi Derek,
    There are three cases that must be considered for your question. I will answer your question directly first, and then mention the other two cases.

    Case #1:
    Think of “default-information originate” as a safety check. Suppose there was some careless BGP admin that told a router to redistribute some other protocol’s routes into BGP, say EIGRP. If that admin didn’t use a route-map or some other filter, and he didn’t think about that EIGRP was advertising a default route, the consequences could be really bad. You might not want all of your BGP peers to

    ... Continue reading in our forum

  2. Hi Rouzbeh,

    1. If no mask is specified, default mask is used, that is /8 in your example.
    2. When Rene said “exact mask has to be added in network command” meant that if we have a prefix in routing table (say 192.168.1.0/25), and we want this prefix to be injected in bgp with network command we should use
    router bgp 1
    network 192.168.1.0 255.255.255.128
    

    in our config.
    If we are going to use:

    router bgp 1
    network 192.168.1.0
    

    , router will assume an implicit mask (255.255.255.0).
    So 192.168.1.0/24 prefix will not enter bgp table because we do not have 192.168.1.0/2

    ... Continue reading in our forum

  3. Hello Mohammad

    BGP does use triggered updates when it learns of a change on its internal domain. However, there are a few things that affect the operation of this triggering that will in turn affect the behaviour of BGP.

    Lets say that there is a network on the internal domain that is learned via OSPF, and this network continually goes up and down. BGP updates will be affected by the following:

    1. The detection of the changes - how fast does the router detect that the OSPF route is down? This depends primarily on the BGP scanner process. This process walks th

    ... Continue reading in our forum

  4. Hello Hussein,

    That is no problem. You advertise the network with the network command and then use route-maps to filter what you need.

    Here’s R1 advertising to R2:

    R1#show ip bgp neighbors 192.168.12.2 advertised-routes 
    BGP table version is 4, local router ID is 1.1.1.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
                  r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
                  x best-external, a additional-path, c RIB-compressed, 
                  t secondary path, 
    Origin codes: i - IGP, e - EGP, 
    ... Continue reading in our forum

  5. Hello Hussein,

    I’m afraid you can’t do this. With BGP, the network command adds something to the global BGP table and then you can use route-maps to decide if you want to advertise something or not to your neighbors.

    What exactly are you trying to do? If you want something where you don’t advertise anything to a neighbor unless you configure it to do so, then you still could use a route-map with some regular expressions. For example, let’s say you don’t want to advertise anything by default that you added to the BGP table then you can use a route-map with a reg

    ... Continue reading in our forum

48 more replies! Ask a question or join the discussion by visiting our Community Forum