IS-IS Redistribution

IS-IS, like any other other routing protocol supports redistribution. Configuring this is pretty straight-forward so that’s what I will show you in this lesson.

Configuration

Here is the topology that we will use:

is-is redistribution topology

Above we have four routers. R2 and R3 are in area 23, R4 is sitting alone in area 4. R1 is running EIGRP and we use it to advertise its loopback interface to R2. Redistribution will be configured on R2.

Configurations

Want to take a look for yourself? Here you will find the startup configuration of each device.

R1

hostname R1
!
ip cef
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/1
 ip address 192.168.12.1 255.255.255.0
!
router eigrp 12
 network 1.1.1.1 0.0.0.0
 network 192.168.12.0
!
end

R2

hostname R2
!
ip cef
!
interface GigabitEthernet0/1
 ip address 192.168.12.2 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 192.168.23.2 255.255.255.0
 ip router isis 
!
router eigrp 12
 network 192.168.12.0
!
router isis
 net 49.0023.0000.0000.0002.00
 is-type level-1
 log-adjacency-changes
!
end

R3

hostname R3
!
ip cef
!
interface GigabitEthernet0/1
 ip address 192.168.23.3 255.255.255.0
 ip router isis 
!
interface GigabitEthernet0/2
 ip address 192.168.34.3 255.255.255.0
 ip router isis 
!
router isis
 net 49.0023.0000.0000.0003.00
 log-adjacency-changes
!
end

R4

hostname R4
!
ip cef
!
interface GigabitEthernet0/1
 ip address 192.168.34.4 255.255.255.0
 ip router isis 
!
router isis
 net 49.0004.0000.0000.0004.00
 is-type level-2-only
 log-adjacency-changes
!
end

Let’s make sure that R2 has an EIGRP route in its routing table:

R2#show ip route eigrp 

      1.0.0.0/32 is subnetted, 1 subnets
D        1.1.1.1 [90/130816] via 192.168.12.1, 00:50:14, GigabitEthernet0/1

Above we see the 1.1.1.1/32 prefix that we learned from R1. Let’s see if we can redistribute this into IS-IS:

R2(config)#router isis
R2(config-router)#redistribute eigrp 12 ?
  level-1      IS-IS level-1 routes only
  level-1-2    IS-IS level-1 and level-2 routes
  level-2      IS-IS level-2 routes only
  metric       Metric for redistributed routes
  metric-type  OSPF/IS-IS exterior metric type for redistributed routes
  route-map    Route map reference
  <cr>

When you redistribute something into IS-IS, you can choose if it should be added to the level 1 LSP, the level 2 LSP or in both LSPs. Since R2 is a level 1 router, we don’t have much choice. We still have to specify it though:

R2(config-router)#redistribute eigrp 12 level-1 

This will redistribute all EIGRP routes into the level 1 database of R2. Let’s also redistribute the IS-IS routes back into EIGRP so that we have full connectivity:

R2(config-router)#router eigrp 12  
R2(config-router)#redistribute isis level-1 metric 1 1 1 1 1 

That’s all we have to do.

Verification

Let’s see if R3 learned anything from R2:

R3#show isis database level-1 verbose 

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
R2.00-00              0x00000007   0x2B20        941               0/0/0
  Area Address: 49.0023
  NLPID:        0xCC 
  Hostname: R2
  Metric: 10         IS R3.01
  IP Address:   192.168.23.2
  Metric: 10         IP 192.168.23.0 255.255.255.0
  Metric: 0          IP-External 1.1.1.1 255.255.255.255
  Metric: 0          IP-External 192.168.12.0 255.255.255.0
R3.00-00            * 0x00000005   0x46E2        520               1/0/0
  Area Address: 49.0023
  NLPID:        0xCC 
  Hostname: R3
  Metric: 10         IS R3.01
  IP Address:   192.168.34.3
  Metric: 10         IP 192.168.23.0 255.255.255.0
  Metric: 10         IP 192.168.34.0 255.255.255.0
R3.01-00            * 0x00000002   0x9BB1        540               0/0/0
  Metric: 0          IS R3.00
  Metric: 0          IS R2.00

Above we see the two EIGRP networks that have been redistributed into IS-IS. There’s 1.1.1.1/32 and 192.168.12.0/24 (the link in between R1 and R2). Note that the default metric of external routes is 0. These will be installed in the routing table of R3:

R3#show ip route isis

      1.0.0.0/32 is subnetted, 1 subnets
i L1     1.1.1.1 [115/10] via 192.168.23.2, 00:03:31, GigabitEthernet0/1
i L1  192.168.12.0/24 [115/10] via 192.168.23.2, 00:03:31, GigabitEthernet0/1

In the routing table itself, these routes show up as regular level 1 routes. You won’t see that they are external.

In the database of R3, we see that the redistributed routes are external. This information, however, is lost when R3 copies the prefixes from its level 1 to level 2 database:

R3#show isis database level-2 verbose R3.00-00


IS-IS Level-2 LSP R3.00-00
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
R3.00-00            * 0x00000009   0xE59D        669               0/0/0
  Area Address: 49.0023
  NLPID:        0xCC 
  Hostname: R3
  Metric: 10         IS R4.01
  IP Address:   192.168.34.3
  Metric: 10         IP 192.168.23.0 255.255.255.0
  Metric: 10         IP 192.168.34.0 255.255.255.0
  Metric: 10         IP 1.1.1.1 255.255.255.255
  Metric: 10         IP 192.168.12.0 255.255.255.0

We see the two redistributed prefixes in the level 2 LSP of R2 but there’s no reference to external anymore.

When you redistribute something into level-2 directly, it will show up as external. This will even remain when advertised to other level 2 routers in different areas.

Let’s take a look at R4:

R4#show isis database level-2 verbose 

IS-IS Level-2 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
R3.00-00              0x00000007   0xE99B        829               0/0/0
  Area Address: 49.0023
  NLPID:        0xCC 
  Hostname: R3
  Metric: 10         IS R4.01
  IP Address:   192.168.34.3
  Metric: 10         IP 192.168.23.0 255.255.255.0
  Metric: 10         IP 192.168.34.0 255.255.255.0
  Metric: 10         IP 1.1.1.1 255.255.255.255
  Metric: 10         IP 192.168.12.0 255.255.255.0
R4.00-00            * 0x00000005   0x471D        1059              0/0/0
  Area Address: 49.0004
  NLPID:        0xCC 
  Hostname: R4
  Metric: 10         IS R4.01
  IP Address:   192.168.34.4
  Metric: 10         IP 192.168.34.0 255.255.255.0
R4.01-00            * 0x00000003   0x4889        1028              0/0/0
  Metric: 0          IS R4.00
  Metric: 0          IS R3.00

R4 has received the level 2 LSP from R3 and will install the prefixes in its routing table:

R4#show ip route isis

      1.0.0.0/32 is subnetted, 1 subnets
i L2     1.1.1.1 [115/20] via 192.168.34.3, 00:06:42, GigabitEthernet0/1
i L2  192.168.12.0/24 [115/20] via 192.168.34.3, 00:06:42, GigabitEthernet0/1
i L2  192.168.23.0/24 [115/20] via 192.168.34.3, 00:28:17, GigabitEthernet0/1

That’s all there is to it.

Configurations

Want to take a look for yourself? Here you will find the final configuration of each device.

R1

hostname R1
!
ip cef
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/1
 ip address 192.168.12.1 255.255.255.0
!
router eigrp 12
 network 1.1.1.1 0.0.0.0
 network 192.168.12.0
!
end

R2

hostname R2
!
ip cef
!
interface GigabitEthernet0/1
 ip address 192.168.12.2 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 192.168.23.2 255.255.255.0
 ip router isis 
!
router eigrp 12
 network 192.168.12.0
 redistribute isis level-1 metric 1 1 1 1 1
!
router isis
 net 49.0023.0000.0000.0002.00
 is-type level-1
 log-adjacency-changes
 redistribute eigrp 12 level-1
!
end

R3

hostname R3
!
ip cef
!
interface GigabitEthernet0/1
 ip address 192.168.23.3 255.255.255.0
 ip router isis 
!
interface GigabitEthernet0/2
 ip address 192.168.34.3 255.255.255.0
 ip router isis 
!
router isis
 net 49.0023.0000.0000.0003.00
 log-adjacency-changes
!
end

R4

hostname R4
!
ip cef
!
interface GigabitEthernet0/1
 ip address 192.168.34.4 255.255.255.0
 ip router isis 
!
router isis
 net 49.0004.0000.0000.0004.00
 is-type level-2-only
 log-adjacency-changes
!
end

Conclusion

When redistributing into IS-IS, you have to specify if the redistributed routes have to be added to the level 1 or level 2 LSP, or both. If you don’t specify a metric, then the default metric is 0. Redistributed routes will show up as “external” in the database but this information is lost when the LSP is copied from level 1 to level 2.

Tags: ,


Forum Replies

  1. Hi Rene,
    Is there any rule to connected other Routing protocol or we can do redistribution any where suppose L1/L2 or L1-L2 Router?? Thanks

    br//zaman

  2. Hi Zaman,

    Not really, when you redistribute something into IS-IS you can do it on any router and redistribute into L1, L2 or both L1 and L2.

    Rene

  3. Hi Rene,
    I have set up a LAB with multiple ISIS Instance/TAG . Then Redistribute those Instances with each other using Route-Map matching Loopback IP’s and TAG value. But I am not getting 2.2.2.2/32 prefix from R1 and 4.4.4.4/32, 44.44.44.44/32 prefix from R3 whether I configured Instance Redistribution on R2 and R4 .Please check the topology & Configuration attached.ISIS config !!.txt (3.5 KB)

    //cdn-forum.networklessons.com/uploads/default/original/2X/7/75345041b54bd8a1005cea61f7dab1089cbe8905.jpeg

    Thanks

    BR//ZAMAN

  4. Hello Zaman,

    If you lab up something like this, first try the basic redistribution commands without route-maps or tags (maybe you did).

    I labbed up redistribution between IS-IS processes on IOSv (Cisco VIRL) but whatever I tried, it was impossible to redistribute routes from one process into another. Maybe it’s related to Cisco IOS or the version that I used. The commands are accepted but it doesn’t redistribute anything.

    On IOS XR, it works. Here’s a working configuration for three routers connected like this:

    R1-R2-R3

    hostname R1
    !
    interface GigabitEthernet0/
    ... Continue reading in our forum

  5. Hi,
    Thanks Rene for your valuable input . In My LAB Only local connected (Loopback) prefix will not distributed But others prefix distributed fine . In R2 , when redistributed (24 to AREA12) to AREA12 , only 2.2.2.2/32 prefix not come to AREA12 but all others prefix (3.3.3.3/32 ; 4.4.4.4/32) redistributed fine . See the output below :

    R1#show ip route 
    Gateway of last resort is not set
    
     1.0.0.0/32 is subnetted, 1 subnets
    C        1.1.1.1 is directly connected, Loopback0
          3.0.0.0/32 is subnetted, 1 subnets
    **i L2     3.3.3.3 [115/30] via 192.168.12.2, 00:0
    ... Continue reading in our forum

1 more reply! Ask a question or join the discussion by visiting our Community Forum