IS-IS Metric on Cisco IOS

IS-IS supports four different metric values:

  • Default Metric: every interface has a default metric of 10.
  • Delay: similar to how EIGRP uses delay.
  • Expense: the actual monetary cost of a link.
  • Error: similar to how EIGRP uses reliability.

Cisco IOS routers, however, only support the default metric. The other metric values are not used. The default metric is always set to 10, no matter the interface. A Ten Gigabit interface gets the same metric as a slow serial link.

In practice, this means that IS-IS will act similar to RIP, the path with the least amount of hops will be used. This is something you might want to change.

In this lesson, I’ll show you how we can configure the metric and some other tricks.

Configuration

Here’s the topology I will use:

is-is area 1234 four routers

We have four routers in a single area, these routers are configured as level 1 routers.

Configurations

Want to take a look for yourself? Here you will find the startup configuration of each device.

R1

hostname R1
!
ip cef
!
interface GigabitEthernet0/1
 ip address 192.168.12.1 255.255.255.0
 ip router isis 
!
interface GigabitEthernet0/2
 ip address 192.168.13.1 255.255.255.0
 ip router isis 
!
router isis
 net 49.1234.0000.0000.0001.00
 is-type level-1
 log-adjacency-changes
!
end

R2

hostname R2
!
ip cef
!
interface GigabitEthernet0/1
 ip address 192.168.12.2 255.255.255.0
 ip router isis 
!
interface GigabitEthernet0/2
 ip address 192.168.24.2 255.255.255.0
 ip router isis 
!
router isis
 net 49.1234.0000.0000.0002.00
 is-type level-1
 log-adjacency-changes
!
end

R3

hostname R3
!
ip cef
!
interface GigabitEthernet0/1
 ip address 192.168.34.3 255.255.255.0
 ip router isis 
!
interface GigabitEthernet0/2
 ip address 192.168.13.3 255.255.255.0
 ip router isis 
!
router isis
 net 49.1234.0000.0000.0003.00
 is-type level-1
 log-adjacency-changes
!
end

R4

hostname R4
!
ip cef
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ip router isis 
!
interface GigabitEthernet0/1
 ip address 192.168.34.4 255.255.255.0
 ip router isis 
!
interface GigabitEthernet0/2
 ip address 192.168.24.4 255.255.255.0
 ip router isis 
!
router isis
 net 49.1234.0000.0000.0004.00
 is-type level-1
 log-adjacency-changes
!
end

Let’s take a look the routing table of R1:

R1#show ip route isis 

      4.0.0.0/32 is subnetted, 1 subnets
i L1     4.4.4.4 [115/30] via 192.168.13.3, 00:06:43, GigabitEthernet0/2
                 [115/30] via 192.168.12.2, 00:06:43, GigabitEthernet0/1
i L1  192.168.24.0/24 [115/20] via 192.168.12.2, 00:06:43, GigabitEthernet0/1
i L1  192.168.34.0/24 [115/20] via 192.168.13.3, 00:06:43, GigabitEthernet0/2

Above we see that R1 has two equal metric paths for 4.4.4.4/32. Both have a metric of 30 in total. We have to cross two GigabitEthernet interfaces and the loopback interface is added as well. What if we want to change this? We can do so by setting the metric manually. This is done on the interface level:

R1(config)#interface GigabitEthernet 0/2
R1(config-if)#isis metric ?
  <1-16777214>  Default metric
  maximum       Maximum metric. All routers will exclude this link from their SPF

We can select a different metric or use the maximum command. I’ll show you what this command does is in a minute, let’s start with a custom metric first:

R1(config-if)#isis metric 50 ?
  <1-16777214>  Delay metric
  level-1       Apply metric to level-1 links
  level-2       Apply metric to level-2 links
  <cr>

We can make one more change. You can choose if this metric should apply to level 1, level 2 links or both. If you don’t specify this then it will apply to both. Let’s set the metric of this interface to 50:

R1(config-if)#isis metric 50 

Let’s have another look at the routing table:

R1#show ip route 4.4.4.4 255.255.255.255
Routing entry for 4.4.4.4/32
  Known via "isis", distance 115, metric 30, type level-1
  Redistributing via isis
  Last update from 192.168.12.2 on GigabitEthernet0/1, 00:00:10 ago
  Routing Descriptor Blocks:
  * 192.168.12.2, from 4.4.4.4, 00:00:10 ago, via GigabitEthernet0/1
      Route metric is 30, traffic share count is 1

Since the path through R2 now has the lowest metric, this is the path that IS-IS will use. We can see the metric that was set to 50 in the database though:

R1#show isis database level-1 R1.00-00 detail


IS-IS Level-1 LSP R1.00-00
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
R1.00-00            * 0x00000016   0x2D65        1071              0/0/0
  Area Address: 49.1234
  NLPID:        0xCC 
  Hostname: R1
  Metric: 10         IS-Extended R1.01
  Metric: 50         IS-Extended R3.02
  IP Address:   192.168.13.1
  Metric: 10         IP 192.168.12.0/24
  Metric: 50         IP 192.168.13.0/24

There is a limit to the metric you can set on an interface. For example, if I try to change it 100 this will happen:

R1(config-if)#isis metric 100
Warning: for metrics greater than 63, 'metric-style wide'  should be configured on level-1-2, or it will be capped at 63.

By default, the maximum metric that IS-IS supports to reach any destination is 1023. The maximum metric for an interface is 63. We can change this behavior by using “wide” metrics. We should do this on all routers:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You've Ever Spent on Your Cisco Career!
  • Full Access to our 651 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

555 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Ask a question or start a discussion by visiting our Community Forum