EIGRP Default Network Route

In this lesson we’ll take a look how we can configure a default route in EIGRP.  Basically there are two methods how you can do this:

  • Create a static route and advertise it into EIGRP.
  • Flag an EIGRP route as the default network.

We will take a look at both methods. This is the topology we will use:

EIGRP Default Network Topology

R1 and R2 are configured for EIGRP, R2 is connected to an ISP router. Behind the ISP is network 3.3.3.0 /24 that we can use to test our default route.

Configuration

Here’s the configuration of R1 and R2:

R1#show run | section eigrp
router eigrp 12
 network 192.168.12.0
 no auto-summary
R2#show run | section eigrp
router eigrp 12
 network 192.168.12.0
 no auto-summary

Nothing special, R1 and R2 are neighbors but that’s it.

Static Default Route

Let’s start with the first option, the static default route:

R2(config)#ip route 0.0.0.0 0.0.0.0 FastEthernet 0/1

R2(config)#router eigrp 12
R2(config-router)#network 0.0.0.0

We configure the default route on R2 with FastEthernet 0/1 as the exit interface. In EIGRP we can use the network 0.0.0.0 command to advertise this. This might sound strange but it works, normally you can only use the network command to advertise networks on interfaces but EIGRP wil make an exception for this default route.

When I tested this I had to use the interface as the next hop instead of specifying the next hop IP address. Otherwise the default route won’t be advertised in EIGRP. Instead of using the network command you can also redistribute this network.

Let’s see what R1 thinks of this:

R1#show ip route eigrp | begin 0.0.0.0
Gateway of last resort is 192.168.12.2 to network 0.0.0.0

D*    0.0.0.0/0 [90/30720] via 192.168.12.2, 00:01:11, FastEthernet0/0

R1 has learned the default route.

Configurations

Want to take a look for yourself? Here you will find the configuration of each device.

ISP

hostname ISP
!
interface FastEthernet0/0
 ip address 192.168.23.3 255.255.255.0
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
ip route 192.168.12.0 255.255.255.0 192.168.23.2
!
end

R1

hostname R1
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
!
router eigrp 12
 no auto-summary
 network 192.168.12.0
!
end

R2

hostname R2
!
interface FastEthernet0/1
 ip address 192.168.23.2 255.255.255.0
!
interface FastEthernet1/0
 ip address 192.168.12.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!
router eigrp 12
 no auto-summary
 network 192.168.12.0
 network 0.0.0.0
!
end


Let’s look at the other method. Let’s get rid of the default route now so we can try the other method:

R2(config)#router eigrp 12
R2(config-router)#no network 0.0.0.0          

R2(config)#no ip route 0.0.0.0 0.0.0.0 FastEthernet 0/1

There we go…let’s continue!

IP Default Network

This one is a bit tricky, we can use the ip default-network command to tell other EIGRP routers that this is a network of “last resort”. This means that they can use it as a default route. We will advertise the network between R2 and ISP in EIGRP and configure it as the “default network”:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You've Ever Spent on Your Cisco Career!
  • Full Access to our 657 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

541 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Forum Replies

  1. Hi Rene,

    Is there a tutorial on EIGRP default routes using redistribution?

    Cheers
    Rob

  2. I enjoy your site very much! Thank you for all the great information!

    Regarding this statement -

    "In EIGRP we can use the network 0.0.0.0 command to advertise this. This might sound strange but it works, normally you can only use the network command to advertise networks on interfaces but EIGRP wil [sic] make an exception for this default route."
    Rather than an exception, isn't this the equivalent of "network 0.0.0.0 255.255.255.255"? EIGRP will use a classful wildcard if none is provided, so 0.0.0.0 will count as a class A.

    Testing on IOS 15.2(4), “network

    ... Continue reading in our forum

  3. The second configuration did not work for me as well. I can the interface of the ISP router and get replies but not the loopback of 3.3.3.3

    So it seems to be partly working.

    //cdn-forum.networklessons.com/uploads/default/original/1X/5f17c768ebb82f3a838c88680dbc0f138fc18e25.JPG

    the routes seem fine I am using this version of IOS: c3640-jk9s-mz.124-16.bin

    //cdn-forum.networklessons.com/uploads/default/original/1X/952fbe97dbbd8bbbae07d7fb649062275ac0faf1.JPG

    here is another pic

    //cdn-forum.networklessons.com/uploads/default/original/1X/2a230141ce1547bf618b15789

    ... Continue reading in our forum

  4. Hi @wilder7bc,

    The ip default-network command is one of the weirder commands out there. I think I originally tried it on 12.4 when I wrote the lesson. On IOS 15.x, I can’t make it work…

    The funny thing is, when I load my config, R1 doesn’t see 192.168.23.0/24 as a default network:

    R1#show ip route 
    
    D     192.168.23.0/24 [90/3072] via 192.168.12.2, 00:03:30, GigabitEthernet0/1
    

    Once I remove and re-add the network command on R2, it does get propagated to R1:

    R2(config-router)#router eigrp 12
    R2(config-router)#no network 192.168.23.0
    R2(config-router)#network 19
    ... Continue reading in our forum

  5. Hello Minghui

    When you use an Ethernet port as an exit interface, what will happen depends on several factors including the IOS version and the platform that you are using. In some platforms/IOS combinations, what Rene has implemented will work as configured. However, there are some other situations in which it doesn’t. The following link shows a couple of examples where you have an IP address as a next hop IP or an interface as an exit interface. In this example, the use of an exit interface fails.

    ... Continue reading in our forum

25 more replies! Ask a question or join the discussion by visiting our Community Forum