How to configure RIP on a Cisco router

RIP (Routing Information Protocol) is one of the routing protocols you need to understand if you want to pass the Cisco CCNA exam. If you have no idea how RIP works I suggest to read this lesson first where I explain how RIP works. In this lesson I’ll show you how to configure RIP on a Cisco router. This is the topology that I will use:

rip 3 routers

Above we see 3 routers called R1, R2 and R3. There are a couple of networks so we’ll have something to advertise in RIP. First let’s configure all the interfaces:

R1>enable 
R1#configure terminal 
R1(config)#interface fastEthernet 0/0
R1(config-if)#no shutdown
R1(config-if)#ip address 172.16.1.1 255.255.255.0
R1(config-if)#exit
R1(config)#interface fastEthernet 1/0
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown
R2>enable
R2#configure terminal
R2(config)#interface fastEthernet 0/0
R2(config-if)#no shutdown
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#exit
R2(config)#interface FastEthernet 1/0
R2(config-if)#no shutdown
R2(config-if)#ip address 192.168.23.2 255.255.255.0
R2(config-if)#exit

R3>enable
R3#configure terminal
R3(config)#interface fastEthernet 0/0
R3(config-if)#no shutdown
R3(config-if)#ip address 172.16.2.3 255.255.255.0
R3(config-if)#exit
R3(config)#interface fastEthernet 1/0
R3(config-if)#no shutdown
R3(config-if)#ip address 192.168.23.3 255.255.255.0
R3(config-if)#exit

Before we continue RIP we’ll check the routing tables:

R1#show ip route     
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - S-IS level-2
       ia - IS-IS inter area, * - candidate default, 
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet1/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
R2#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - S-IS level-2
       ia - IS-IS inter area, * - candidate default, 
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
C    192.168.23.0/24 is directly connected, FastEthernet1/0
R3#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - S-IS level-2
       ia - IS-IS inter area, * - candidate default, 
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.2.0 is directly connected, FastEthernet0/0
C    192.168.23.0/24 is directly connected, FastEthernet1/0

Our routers only know 1 thing…their directly connected interfaces. Let’s configure RIP and see what happens:

R1(config)#router rip
R1(config-router)#network 192.168.12.0
R1(config-router)#network 172.16.1.0
R2(config)#router rip
R2(config-router)#network 192.168.12.0

We use the router rip command to go to the RIP configuration. Next step is to use the network command which does two things:

Let’s zoom in on R1 and R2 so I can explain this a bit more…

rip send updates both ways

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You've Ever Spent on Your Cisco Career!
  • Full Access to our 660 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

507 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Forum Replies

  1. Rene,
    I’m using the Boson Netsim 9.0 simulator and I configured a lab to match what you laid out in this lesson, what has me baffled is how and where do you see the hop count message of 16, when I shutdown the interface on my R3 router (LAN) 3.3.3.0/24. I turned on debug IP Rip on my R2 router to view the updates being sent from R3. I did see the metric count reach 4 and after that the route was deleted for network 3.3.3.0/24, I never saw the hop count reach 16…just curious about this.
    Otherwise a very good explanation and write up RIP protocol
    It could be the

    ... Continue reading in our forum

  2. Hello Sameer

    This is a very good question. What is happening here is that R2 has obtained its original hop count of 1 to network 3.3.3.3 from R3. So since R3 has told R2 that the distance to 3.3.3.3 is 1, it puts it in its routing table.

    After the procedure that is described, R3 sends a new hop count to R2 of 2. Now you say since this hop count is higher than that which is already in the routing table of R2, why does R2 replace it? Well, it will replace it because it is an updated piece of information.

    So, the previous entry of metric 1 that was learned fr

    ... Continue reading in our forum

  3. Hello Sameer

    RIP requests are only sent under special circumstances, when a router requires that it be provided with immediate routing information. The most common example of this is when a router is first powered on. After initializing, the router will typically send an RIP Request on its attached networks to ask for the latest information about routes from any neighboring routers. The only other situation in which RIP requests are sent is when they are to be used for diagnostic purposes.

    So yes, it is rare to find requests.

    Responses on the other hand are sen

    ... Continue reading in our forum

  4. Super, Nice explanation Liz, now i understand the behaviour of RIPV1.

  5. Thanks again Lazaros,
    Now it is clear for me.

53 more replies! Ask a question or join the discussion by visiting our Community Forum