BGP Auto-Summary

In a previous lesson I explained how the BGP network command works. When we enable auto-summary for BGP, the way the network command works changes slightly.

Normally when you advertise a network in BGP you have to type in the exact network and subnet mask that you want to advertise or it won’t be placed in the BGP table.

With auto-summary enabled, you can advertise a classful network and you don’t have to add the mask parameter. BGP will automatically advertise the classful network if you have the classful network or a subnet of this network in your routing table. Let me give you an example to explain what I’m talking about. I’ll use these two routers:

BGP R1 R2 AS1 AS2 Topology

These routers are configured for eBGP, there’s a loopback interface on R1 with network 1.1.1.1 /32. Here’s the configuration:

R1#show run | section bgp
router bgp 1
 bgp log-neighbor-changes
 neighbor 192.168.12.2 remote-as 2
R2#show run | section bgp
router bgp 2
 bgp log-neighbor-changes
 neighbor 192.168.12.1 remote-as 1

The configuration is straight-forward, we only configured eBGP, no networks have been advertised and auto-summary is disabled. Let’s see if we can advertise classful network 1.0.0.0/8:

R1(config)#router bgp 1
R1(config-router)#network 1.0.0.0

Note that I didn’t specify a subnet mask with the mask parameter. Take a look at the BGP table now:

R1#show ip bgp 1.0.0.0
% Network not in table

As expected there is nothing in the BGP table since we require the exact network and subnet mask. Let’s enable auto-summary now so you can see the difference:

R1(config)#router bgp 1
R1(config-router)#auto-summary

After enabling auto-summary things will change. Take a look at the BGP table of R1:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You’ve Ever Spent on Your Cisco Career!
  • Full Access to our 710 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

457 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Forum Replies

  1. Hi Rene,

    So I am assuming [no auto-summary] is the default on BGP? Also, is there a command to see whether auto-sum is enabled or not. When I run [show run | section bgp] there is no mention of auto-sum.

    Thanks,
    Mario

  2. Hi Mario,

    No auto-summary is the default for BGP. It’s one of those commands that doesn’t show up in the running-config because it’s default.

    I think you can see it with “show run all” though.

    Rene

  3. Hi Rene,

    I have followed the same config you have explained but it’s not working at all.
    Refer to the below outputs.

    IOU1#show run int lo0
    Building configuration...
    
    Current configuration : 61 bytes
    !
    interface Loopback0
     ip address 1.1.1.1 255.255.255.0
    end
    
    IOU1#show run | s bgp
    router bgp 1
     bgp log-neighbor-changes
     network 1.0.0.0
     neighbor 192.168.12.2 remote-as 2
     auto-summary
    IOU1#show ip bgp summ
    BGP router identifier 192.168.12.1, local AS number 1
    BGP table version is 1, main routing table version 1
    
    Neighbor        V           AS MsgRcvd MsgSent   T
    ... Continue reading in our forum

  4. Hi,

    If we can advertise exact network and subnet mask so whats is the need of auto-summary command?

    What would be the reason to advertise network address without subnet mask? can you please give example of the network where have to advertise a network without subnet mask and then use auto-summary command?

  5. Hello Card

    BGP Auto-Summary is useful when you have many different subnets that you want to advertise. For example, let’s say you have 250 subnets of the form:

    147.52.0.0/24
    147.52.1.0/24
    147.52.2.0/24

    and
    149.55.26.0/25
    149.55.26.129/25
    149.55.27.0/25

    and
    152.66.25.30/28
    152.66.26.30/28
    152.66.27.30/28

    These are all discontiguous networks and if you want to advertise them all, you have to explicitly state each one with its subnet mask. That’s 250 network commands. You can use the auto-summary command to simplify configuration and reduce the number of ne

    ... Continue reading in our forum

5 more replies! Ask a question or join the discussion by visiting our Community Forum