DMVPN Phase 3 Basic Configuration

DMVPN supports three different versions called “phases”. In my first DMVPN lesson I explained the basics and  the DMVPN phase 2 configuration and DMVPN phase 1 configuration lessons explain how to configure the first two phases.

This time, I’ll show you how to configure DMVPN phase 3. We’ll use the following topology for this:

dmvpn-example-topology

We have one hub router and two spoke routers.

Configuration



The configuration of DMVPN phase 3 and 2 is very similar. Let’s start with the following DMVPN phase 2 configuration on all routers:

Hub(config)#interface Tunnel0
Hub(config-if)#ip address 172.16.123.1 255.255.255.0
Hub(config-if)#ip nhrp authentication DMVPN
Hub(config-if)#ip nhrp map multicast dynamic
Hub(config-if)#ip nhrp network-id 1
Hub(config-if)#tunnel source GigabitEthernet0/1
Hub(config-if)#tunnel mode gre multipoint
Spoke1(config)#interface Tunnel0
Spoke1(config-if)#ip address 172.16.123.2 255.255.255.0
Spoke1(config-if)#ip nhrp authentication DMVPN
Spoke1(config-if)#ip nhrp map 172.16.123.1 192.168.123.1
Spoke1(config-if)#ip nhrp map multicast 192.168.123.1
Spoke1(config-if)#ip nhrp network-id 1
Spoke1(config-if)#ip nhrp nhs 172.16.123.1
Spoke1(config-if)#tunnel source GigabitEthernet0/1
Spoke1(config-if)#tunnel mode gre multipoint
Spoke2(config)#interface Tunnel0
Spoke2(config-if)#ip address 172.16.123.3 255.255.255.0
Spoke2(config-if)#ip nhrp authentication DMVPN
Spoke2(config-if)#ip nhrp map 172.16.123.1 192.168.123.1
Spoke2(config-if)#ip nhrp map multicast 192.168.123.1
Spoke2(config-if)#ip nhrp network-id 1
Spoke2(config-if)#ip nhrp nhs 172.16.123.1
Spoke2(config-if)#tunnel source GigabitEthernet0/1
Spoke2(config-if)#tunnel mode gre multipoint

To migrate from DMVPN phase 2 to 3, we only need two commands…here’s the first command:

Hub(config)#interface tunnel 0
Hub(config-if)#ip nhrp redirect 

The NHRP redirect command on the hub will inform spoke routers that they can reach another spoke router directly. The second command is needed on the spoke routers:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You've Ever Spent on Your Cisco Career!
  • Full Access to our 651 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

567 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Forum Replies

  1. Hi !

    I didnt have “ip nhrp redirect” in my IOS (C3745-ADVENTERPRISEK9_SNA-M) ??? that´s the only one i got…

     

    /Oskar

  2. Hello,

    Should router do icmp redirection to his neighbors when they are in one subnet? This feature of IP protocol doesn’t work in this case, does it?
    I see that you disable icmp redirects by issuing “no ip redirects” command on Tunnel interface.

  3. Hi Rene, may be a trivial question but I have not played with GNS3 much. How do you simulate cloud like in this topology?

  4. Hello Rene,
    First, thanks for your great job! it’s really simple to understand

    I have a problem with the configuration of the phase 3 DMVPN in GNS3. Since i type the 'ip nhrp redirect’command, i have te following error message ‘% NHRP-WARNING: ‘ip nhrp redirect’ failed to initialise’
    Could you please tell me why? I use the 7200 ios version 15.2.

    Thanks for your reply

  5. Hi Renee!
    Great lesson as always

    I was just wondering what about the “ip nhrp server-only” what is the purpose of the command??

    -Dan

20 more replies! Ask a question or join the discussion by visiting our Community Forum