Cisco SD-WAN BGP Configuration

Cisco SD-WAN routers use OMP for routing information on the overlay network. Within a site, sometimes you need an IGP like OSPF or perhaps BGP.

This lesson will explain how to configure BGP between a Cisco IOS device and a Cisco SD-WAN vEdge router. We’ll use feature and device templates to accomplish this.

Configuration










Here is the topology we’ll use:

Cisco Sd Wan Vedge1 Sw1 Bgp Topology

Nothing fancy. We only have our vEdge1 router and SW1. I pre-configured SW1 with BGP. I’m using Cisco SD-WAN version 19.3.0.

Configurations

Want to take a look for yourself? Here you will find the startup configuration of each device.

vEdge1

system
 host-name               vEdge1
 system-ip               172.16.1.1
 site-id                 2
 sp-organization-name    nwl-lab-sdwan
 organization-name       nwl-lab-sdwan
 vbond 10.1.0.2
!
omp
 no shutdown
 graceful-restart
 advertise connected
 advertise static
!
vpn 0
 interface ge0/0
  ip address 10.65.91.1/24
  tunnel-interface
   encapsulation ipsec
   color biz-internet
   allow-service all
  !
  no shutdown
 !
 interface ge0/1
  ip address 10.65.92.1/24
  tunnel-interface
   encapsulation ipsec
   color public-internet
   allow-service all
  !
  no shutdown
 !
 ip route 10.1.0.0/24 10.65.91.100
!
vpn 10
 interface ge0/3
  ip address 10.2.1.1/24
  no shutdown
 !
 omp
  advertise connected
 !
!
vpn 512
 interface eth0
  shutdown

SW1

hostname SW1
!
ip cef
!
interface Loopback0
 ip address 11.11.11.11 255.255.255.255
!
interface GigabitEthernet0/0
 no switchport
 ip address 10.2.1.101 255.255.255.0
!
router bgp 1
 bgp log-neighbor-changes
 network 11.11.11.11 mask 255.255.255.255
 neighbor 10.2.1.1 remote-as 1
!
end

SW2

hostname SW2
!
ip cef
!
interface Loopback0
 ip address 22.22.22.22 255.255.255.255
!
interface GigabitEthernet0/1
 no switchport
 ip address 10.2.2.102 255.255.255.0
!
router ospf 1
 network 10.2.2.0 0.0.0.255 area 1
 network 22.22.22.22 0.0.0.0 area 1
!
end

Let’s configure the vEdge1 router.

Feature Template: BGP

Go to Configuration > Templates > Feature and click on Add Template:

Cisco Sd Wan Feature Template Bgp

Specify a name:

Cisco Sd Wan Feature Template Bgp Name

Scroll down to NEIGHBOR and click on New Neighbor:

Cisco Sd Wan Feature Template Bgp Neighbor

Fill in the Address and click on Add:

Cisco Sd Wan Feature Template Bgp Neighbor Address

Our neighbor now shows up in the overview:

Cisco Sd Wan Feature Template Bgp Neighbor Overview

All the other settings are OK. Scroll down and click on Save.

Device Template

Go to Configuration > Templates > Device and edit the device template, which is attached to vEdge1:

Cisco Sd Wan Device Template Bgp Edit

Scroll down to Service VPN and select BGP under the Additional VPN Templates:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You’ve Ever Spent on Your Cisco Career!
  • Full Access to our 739 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

545 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!