MPLS Traffic Engineering (TE) IS-IS Configuration

In this lesson, I’ll explain how to configure MPLS TE on your Cisco IOS routers. Before you continue, make sure you are familiar with MPLS and link-state routing protocols like OSPF and IS-IS is required. Also, you should have a basic understanding of MPLS TE as explained in the introduction lesson.

This is the topology we’ll use:

Mpls Te Pe C Router Topology

Routers PE1, P1, P2, P3, and PE2 are our MPLS core network. The CE1 and CE2 routers use regular IP routing. All routers are configured to use IS-IS L2. I use Cisco IOS Software, IOSv Software (VIOS-ADVENTERPRISEK9-M), Version 15.9(3)M4.

Configurations

Want to take a look for yourself? Here, you will find the startup configuration of each device.

CE1

hostname CE1
!
ip cef
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 ip router isis 
 isis circuit-type level-2-only
!
router isis
 net 49.0001.0001.0001.0001.0001.00
 is-type level-2-only
!
end

CE2

hostname CE2
!
ip cef
!
interface Loopback0
 ip address 7.7.7.7 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet0/0
 ip address 192.168.67.7 255.255.255.0
 ip router isis 
 isis circuit-type level-2-only
!
router isis
 net 49.0001.0007.0007.0007.0007.00
 is-type level-2-only
!
end

P1

hostname P1
!
ip cef
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet0/0
 ip address 192.168.23.3 255.255.255.0
 ip router isis 
 mpls ip
 isis circuit-type level-2-only
!
interface GigabitEthernet0/1
 ip address 192.168.36.3 255.255.255.0
 ip router isis 
 mpls ip
 isis circuit-type level-2-only
!
router isis
 net 49.0001.0003.0003.0003.0003.00
 is-type level-2-only
!
mpls ldp router-id Loopback0 force
!
end

P2

hostname P2
!
ip cef
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet0/0
 ip address 192.168.24.4 255.255.255.0
 ip router isis 
 mpls ip
 isis circuit-type level-2-only
!
interface GigabitEthernet0/1
 ip address 192.168.45.4 255.255.255.0
 ip router isis 
 mpls ip
 isis circuit-type level-2-only
!
router isis
 net 49.0001.0004.0004.0004.0004.00
 is-type level-2-only
!
mpls ldp router-id Loopback0 force
!
end

P3

hostname P3
!
ip cef
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet0/0
 ip address 192.168.56.5 255.255.255.0
 ip router isis 
 mpls ip
 isis circuit-type level-2-only
!
interface GigabitEthernet0/1
 ip address 192.168.45.5 255.255.255.0
 ip router isis 
 mpls ip
 isis circuit-type level-2-only
!
router isis
 net 49.0001.0005.0005.0005.0005.00
 is-type level-2-only
!
mpls ldp router-id Loopback0 force
!
end

PE1

hostname PE1
!
ip cef
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet0/0
 ip address 192.168.12.2 255.255.255.0
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet0/1
 ip address 192.168.23.2 255.255.255.0
 ip router isis 
 mpls ip
 isis circuit-type level-2-only
!
interface GigabitEthernet0/2
 ip address 192.168.24.2 255.255.255.0
 ip router isis 
 mpls ip
 isis circuit-type level-2-only
!
router isis
 net 49.0001.0002.0002.0002.0002.00
 is-type level-2-only
!
mpls ldp router-id Loopback0 force
!
end

PE2

hostname PE2
!
ip cef
!
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet0/0
 ip address 192.168.67.6 255.255.255.0
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet0/1
 ip address 192.168.36.6 255.255.255.0
 ip router isis 
 mpls ip
 isis circuit-type level-2-only
!
interface GigabitEthernet0/2
 ip address 192.168.56.6 255.255.255.0
 ip router isis 
 mpls ip
 isis circuit-type level-2-only
!
router isis
 net 49.0001.0006.0006.0006.0006.00
 is-type level-2-only
!
mpls ldp router-id Loopback0 force
!
end

Before we continue, let’s make sure we have a label-switched path (LSP) when we send traffic from CE1 to CE2:

CE1#traceroute 7.7.7.7 source 1.1.1.1 probe 1
Type escape sequence to abort.
Tracing the route to 7.7.7.7
VRF info: (vrf in name/id, vrf out name/id)
  1 192.168.12.2 1 msec
  2 192.168.23.3 [MPLS: Label 23 Exp 0] 4 msec
  3 192.168.36.6 [MPLS: Label 19 Exp 0] 3 msec
  4 192.168.67.7 4 msec

That seems to be the case.

Configuration

Let’s find out how we configure this “regular” MPLS network into a network that supports MPLS TE. There are four main items we have to configure:

  • Enable MPLS TE support:
    • Globally
    • Interfaces
  • Configure IS-IS to support MPLS TE.
  • Configure RSVP.
  • Configure a tunnel interface.

We configure these items on all MPLS routers where you want to use MPLS TE. Let’s get started.







Global

With the global mpls traffic-eng tunnels command we enable MPLS TE globally:

PE1, P1, P2, P3, and PE2
(config)#mpls traffic-eng tunnels

Interfaces

We have to enable MPLS TE support on all interfaces where we use MPLS. Let me highlight them for you:

Mpls Te Pe C Router Topology Interfaces

This is the configuration:

PE1 and PE2
(config)#interface range GigabitEthernet 0/1 - 2
(config-if-range)#mpls traffic-eng tunnels
P1, P2, and P3
(config)#interface range GigabitEthernet 0/0 - 1
(config-if-range)#mpls traffic-eng tunnels

That’s it.

IS-IS

There are two things we need to configure for IS-IS to support MPLS TE:

  • Change the metric-style to wide to support the new TLVs.
  • Enable MPLS TE support.

The metric style has to be changed on all routers because narrow and wide are incompatible. If you don’t change this on the CE routers as well, you won’t exchange any routing information anymore in IS-IS:

CE1, PE1, P1, P2, P3, PE2, and CE2
(config)#router isis
(config-router)#metric-style wide

On the PE and P routers, we enable MPLS TE support and use the loopback 0 interface for the router ID:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You’ve Ever Spent on Your Cisco Career!
  • Full Access to our 786 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

1210 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Tags:


Forum Replies

  1. Thank you René for include this topics , im in Service Provider Side and this topics are so usefull for me , please we need EVPN topics or segment routing topics!

  2. Hello Dante

    We’re glad you find this topic helpful! If you have more topics that you’re interested in seeing, such as the EVPN topic you mentioned, please feel free to use the Member Ideas page below. You may find that others have suggested the same topics as you, and you can add your voice to theirs.

    https://networklessons.com/member-ideas

    I hope this has been helpful!

    Laz

  3. Hello Rene / Network lessons,

    We are going to install a new MPLS circuit to connect the client locations. The client is asking to test the MPLS circuit to make sure its working fine and we are receiving the expected bandwidth. The client requirement is that they will not have their routers/equipment to test it. We will have to test it on the MPLS service provider equipment.

    How can we accomplish this? I guess we can use iperf command to test the speeds of a circuit right? But then how to test it if we do not have our equipment? Can we connect our laptop/PC dire

    ... Continue reading in our forum

  4. Hello Viral

    Hmm, that’s a strange request. When testing the capabilities of an MPLS circuit, ideally, you need the customer equipment (CE) in place. This is because the performance of the MPLS circuit directly depends upon the configuration and setup of that equipment as well. Otherwise, you are just testing the capabilities of the ISP’s network internally, which doesn’t have much meaning for the customer.

    MPLS is not like a DSL or cable connection, where you perform a simple speed test to see what kinds of speeds you reach. It must be fully up and running,

    ... Continue reading in our forum

  5. Hello Laz,
    Yes the customer wants to test the capabilities of ISP’s network internally before we connect it to the production router/switch at the day of migration. They want to make sure that circuit is working fine and we are getting expected bandwidth.

    I agree that there will be routing between CE and PE. But we get a /30 subnet from MPLS provider as Layer 2 directly connected right? So is there a way i can connect the optical fiber terminating at DMARC point, connect it to some RJ45 converter(not sure if there is one) and connect that to my laptop to run ip

    ... Continue reading in our forum

5 more replies! Ask a question or join the discussion by visiting our Community Forum