MPLS TE Autoroute Destination

Lesson Contents

MPLS Traffic Engineering (TE) autoroute destination automatically installs a static route for your TE tunnel’s destination (tailend router). This saves you the hassle of manually configuring a static route.

Configuration

Let’s try this out. This is the topology we’ll use:

Mpls Te Autoroute Destination Topology

Routers PE1, P1, P2, P3, and PE2 run MPLS TE. We have a TE tunnel where PE1 is the headend and PE2 is the tailend router. I use Cisco IOS XE Software, Version 17.03.04a.

Configurations

Want to take a look for yourself? Here you will find the startup configuration of each device.

CE1

hostname CE1
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet1
 ip address 192.168.12.1 255.255.255.0
 ip router isis 
 isis circuit-type level-2-only
!
router isis
 net 49.0001.0001.0001.0001.0001.00
 is-type level-2-only
 metric-style wide
!
end

CE2

hostname CE2
!
interface Loopback0
 ip address 7.7.7.7 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet1
 ip address 192.168.67.7 255.255.255.0
 ip router isis 
 isis circuit-type level-2-only
!
router isis
 net 49.0001.0007.0007.0007.0007.00
 is-type level-2-only
 metric-style wide
!
end

P1

hostname P1
!
mpls traffic-eng tunnels
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet1
 ip address 192.168.23.3 255.255.255.0
 ip router isis 
 mpls ip
 mpls traffic-eng tunnels
 isis circuit-type level-2-only
 ip rsvp bandwidth 1000000
!
interface GigabitEthernet2
 ip address 192.168.36.3 255.255.255.0
 ip router isis 
 mpls ip
 mpls traffic-eng tunnels
 isis circuit-type level-2-only
 ip rsvp bandwidth 1000000
!
router isis
 net 49.0001.0003.0003.0003.0003.00
 is-type level-2-only
 metric-style wide
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
!
mpls ldp router-id Loopback0 force
!
end

P2

hostname P2
!
mpls traffic-eng tunnels
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet1
 ip address 192.168.24.4 255.255.255.0
 ip router isis 
 mpls ip
 mpls traffic-eng tunnels
 isis circuit-type level-2-only
 ip rsvp bandwidth 1000000
!
interface GigabitEthernet2
 ip address 192.168.45.4 255.255.255.0
 ip router isis 
 mpls ip
 mpls traffic-eng tunnels
 isis circuit-type level-2-only
 ip rsvp bandwidth 1000000
!
router isis
 net 49.0001.0004.0004.0004.0004.00
 is-type level-2-only
 metric-style wide
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
!
mpls ldp router-id Loopback0 force
!
end

P3

hostname P3
!
mpls traffic-eng tunnels
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet1
 ip address 192.168.56.5 255.255.255.0
 ip router isis 
 mpls ip
 mpls traffic-eng tunnels
 isis circuit-type level-2-only
 ip rsvp bandwidth 1000000
!
interface GigabitEthernet2
 ip address 192.168.45.5 255.255.255.0
 ip router isis 
 mpls ip
 mpls traffic-eng tunnels
 isis circuit-type level-2-only
 ip rsvp bandwidth 1000000
!
router isis
 net 49.0001.0005.0005.0005.0005.00
 is-type level-2-only
 metric-style wide
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
!
mpls ldp router-id Loopback0 force
!
end

PE1

hostname PE1
!
mpls traffic-eng tunnels
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!
interface Tunnel1
 ip unnumbered Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 6.6.6.6
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth 750
 tunnel mpls traffic-eng path-option 1 dynamic
!
interface GigabitEthernet1
 ip address 192.168.12.2 255.255.255.0
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet2
 ip address 192.168.23.2 255.255.255.0
 ip router isis 
 mpls ip
 mpls traffic-eng tunnels
 isis circuit-type level-2-only
 ip rsvp bandwidth 1000000
!
interface GigabitEthernet3
 ip address 192.168.24.2 255.255.255.0
 ip router isis 
 mpls ip
 mpls traffic-eng tunnels
 isis circuit-type level-2-only
 ip rsvp bandwidth 1000000
!
router isis
 net 49.0001.0002.0002.0002.0002.00
 is-type level-2-only
 metric-style wide
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
!
mpls ldp router-id Loopback0 force
!
end

PE2

hostname PE2
!
mpls traffic-eng tunnels
!
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet1
 ip address 192.168.67.6 255.255.255.0
 ip router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet2
 ip address 192.168.36.6 255.255.255.0
 ip router isis 
 mpls ip
 mpls traffic-eng tunnels
 isis circuit-type level-2-only
 ip rsvp bandwidth 1000000
!
interface GigabitEthernet3
 ip address 192.168.56.6 255.255.255.0
 ip router isis 
 mpls ip
 mpls traffic-eng tunnels
 isis circuit-type level-2-only
 ip rsvp bandwidth 1000000
!
router isis
 net 49.0001.0006.0006.0006.0006.00
 is-type level-2-only
 metric-style wide
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
!
mpls ldp router-id Loopback0 force
end

Let’s check the tunnel:

PE1#show mpls traffic-eng tunnels Tunnel 1

Name: PE1_t1                              (Tunnel1) Destination: 6.6.6.6
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 1, type dynamic (Basis for Setup, path weight 20)

  Config Parameters:
    Bandwidth: 750      kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    Path-selection Tiebreaker:
      Global: not set   Tunnel Specific: not set   Effective: min-fill (default)
    Hop Limit: disabled
    Cost Limit: disabled
    Path-invalidation timeout: 10000 msec (default), Action: Tear
    AutoRoute: disabled LockDown: disabled Loadshare: 750 [2666666] bw-based
    AutoRoute destination: enabled 
    auto-bw: disabled
    Fault-OAM: disabled, Wrap-Protection: disabled, Wrap-Capable: No
  Active Path Option Parameters:
    State: dynamic path option 1 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
  Node Hop Count: 2

  InLabel  :  -
  OutLabel : GigabitEthernet2, 16
  Next Hop : 192.168.23.3
  RSVP Signalling Info:
       Src 2.2.2.2, Dst 6.6.6.6, Tun_Id 1, Tun_Instance 20
    RSVP Path Info:
      My Address: 192.168.23.2   
      Explicit Route: 192.168.23.3 192.168.36.3 192.168.36.6 6.6.6.6 
      Record   Route:   NONE
      Tspec: ave rate=750 kbits, burst=1000 bytes, peak rate=750 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=750 kbits, burst=1000 bytes, peak rate=750 kbits
  Shortest Unconstrained Path Info:
    Path Weight: 20 (TE)
    Explicit Route: 192.168.23.2 192.168.23.3 192.168.36.3 192.168.36.6 
                    6.6.6.6 

  History:
    Tunnel:
      Time since created: 14 minutes, 19 seconds
      Time since path change: 10 minutes, 25 seconds
      Number of LSP IDs (Tun_Instances) used: 20
    Current LSP: [ID: 20]
      Uptime: 10 minutes, 25 seconds

The tunnel is connected. We don’t use it as you can see in the routing table below:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You’ve Ever Spent on Your Cisco Career!
  • Full Access to our 799 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

557 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!