Any Transport Over MPLS (AToM)

Any Transport over MPLS (AToM) will transport layer 2 frames over a MPLS (Multiprotocol Label Switching) network. This will allow service providers to connect layer 2 networks of customers transparently by using their MPLS backbone. AToM can transport the following:

  • ATM AAL5
  • ATM Cell Relay
  • Ethernet
  • Frame Relay
  • PPP
  • HDLC

I will give you an example how to configure AToM to transport Ethernet over the MPLS backbone, we will use the following topology to do this:

MPLS Atom Ethernet

Above you see a small MPLS backbone that consists of the PE1, P and PE2 router. This ISP only has one customer that has a HQ and Branch. The customer wants to have the HQ and Branch router to be in the same layer 2 segment.

Configuration

First we will enable OSPF to advertise the loopback interfaces, these will be used as the router ID for MPLS LDP:

PE1(config)#router ospf 1
PE1(config-router)#network 192.168.12.0 0.0.0.255 area 0
PE1(config-router)#network 1.1.1.1 0.0.0.0 area 0
P(config)#router ospf 1
P(config-router)#network 192.168.12.0 0.0.0.255 area 0
P(config-router)#network 192.168.23.0 0.0.0.255 area 0
P(config-router)#network 2.2.2.2 0.0.0.0 area 0
PE2(config)#router ospf 1
PE2(config-router)#network 192.168.23.0 0.0.0.255 area 0
PE2(config-router)#network 3.3.3.3 0.0.0.0 area 0

Now we will enable MPLS LDP on the interfaces connecting the PE1, P and PE2 routers:

PE1(config)#interface fastEthernet 0/1
PE1(config-if)#mpls ip
P(config)#interface fastEthernet 0/0
P(config-if)#mpls ip

P(config)#interface fastEthernet 0/1
P(config-if)#mpls ip 
PE2(config)#interface fastEthernet 0/0
PE2(config-if)#mpls ip

Just to be sure let’s verify that we have LDP neighbors:

P#show mpls ldp neighbor | include Peer
    Peer LDP Ident: 1.1.1.1:0; Local LDP Ident 2.2.2.2:0
    Peer LDP Ident: 3.3.3.3:0; Local LDP Ident 2.2.2.2:0

That seems to be the case! Now we can configure AToM so that the HQ and Branch router are able to reach each other:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Full Access to our 655 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

546 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Tags:


Forum Replies

  1. Hi Georgi,
    These terms all start to run together don’t they?

    First, let’s talk about AToM vs EoMPLS. EoMPLS is AToM that is transporting a specific protocol (Ethernet). AToM is capable of transporting other layer 2 protocols as well, so it has a more broad meaning. The confusion is that most people use Ethernet at layer 2, so in that case EoMPLS and AToM appears to be the same thing. Think of it this way: EoMPLS is a specific kind of AToM just like a Poodle is a specific kind of Dog.

    Now let’s talk about L2TPv3 vs EoMPLS. These are both trying to accompli

    ... Continue reading in our forum

  2. Davis,
    With a network backbone that doesn’t support jumbo frames (meaning frames larger than 1500), you might have some trouble. Common practice is to set the entire core to support an MTU of 9216. You would have to support 14 bytes for Ethernet, 4 bytes for a VLAN tag (if you are using 802.1Q), 4 bytes for MPLS. So, far, that is 22 bytes of overhead, which would reduce your payload size to 1478. Whether you can force your MTU down so your core won’t exceed 1500 bytes, I just don’t know.

    I did find an article that might be of help, though:
    http://www.netcra

    ... Continue reading in our forum

  3. Hi Rene,

    Need your awesome lesson regarding VPLS/HVPLS/MPLS-TE very soon .The topic need to learn badly & you know your write up is simply excellent as compared to any other , Challenge !!! .So ,eagerly waiting for your excellent lesson.Thx

    br//zaman

30 more replies! Ask a question or join the discussion by visiting our Community Forum