EIGRP Auto-Summary

EIGRP supports automatic summarization which as the name implies means that it will automatically advertise summary routes to other EIGRP routers.

How does it work? EIGRP is not going to automatically create the most optimal summary routes for you…

EIGRP will check if you have any subnets that fall within the range of your network command(s) and if so, it will advertise the classful A, B or C network to its neighbors. It will only summarize routes from subnets on its own interfaces, not the ones you learn from other routers.

Instead of advertising specific subnets we will only advertise class A,B or C networks. I’ll walk you through this, here’s the first topology we will use to demonstrate all of this:

EIGRP Auto Summary Example

Above we have two routers, R1 has two loopback interfaces with subnets that we’ll advertise in EIGRP.

Let’s configure EIGRP:

R1(config)#router eigrp 1
R1(config-router)#auto-summary
R1(config-router)#network 192.168.12.0
R1(config-router)#network 1.1.1.0 0.0.0.255
R1(config-router)#network 172.16.1.0 0.0.0.255
R2(config)#router eigrp 1
R2(config-router)#network 192.168.12.0

In the configuration above I enabled auto-summary on R1 which is advertising its loopback interfaces.

Depending on your IOS version, auto-summary might be enabled or disabled by default.

Let’s take a look at the routing table of R2:

R2#show ip route eigrp 
D    1.0.0.0/8 [90/409600] via 192.168.12.1, 00:03:40, FastEthernet0/0
D    172.16.0.0/16 [90/409600] via 192.168.12.1, 00:00:26, FastEthernet0/0

Since auto-summary is enabled, R1 is advertising 1.0.0.0 /8 (class A network) and 172.16.0.0 /16 (class B network).

In our small network this will work fine. When R2 wants to reach 172.16.1.0 /24 or 1.1.1.0 /24 then it will send its packets towards R1. We will run into issues however when we add a third router that will advertise the same summary route. Here’s an example:

EIGRP Discontigious Network

Above I have added R3 behind R2 and it has subnet 1.3.3.0 /24 on a loopback interface. When we enable auto-summary on R3 then it will advertise subnet 1.3.3.0 /24 as the classful network 1.0.0.0 /8. This will be a problem since R2 will think it has two equal paths to reach 1.0.0.0 /8. We call this a discontigious network. Let me demonstrate this:

R2(config)#router eigrp 1
R2(config-router)#network 192.168.23.0
R3(config)#router eigrp 1    
R3(config-router)#auto-summary 
R3(config-router)#network 192.168.23.0
R3(config-router)#network 1.3.3.0 0.0.0.255

Above I enabled EIGRP on the link between R2 and R3 and we use the network command to advertise 1.3.3.0 /24, auto-summary is enabled on R3. Let’s see what R2 thinks of this:

R2#show ip route eigrp 
D    1.0.0.0/8 [90/409600] via 192.168.23.3, 00:00:03, FastEthernet0/1
               [90/409600] via 192.168.12.1, 00:00:03, FastEthernet0/0
D    172.16.0.0/16 [90/409600] via 192.168.12.1, 00:00:13, FastEthernet0/0

R2 believes it can reach 1.0.0.0 /8 through R1 or R3. This will cause issues…when R2 wants to reach 1.1.1.0 /24 then it might send packets to R3 and when it tries to reach 1.3.3.0 /24 then they might end up at R1.

How can we solve this? There are two solutions:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You've Ever Spent on Your Cisco Career!
  • Full Access to our 662 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

519 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Forum Replies

  1. awesome lessons. especially the

    “EIGRP auto-summary will only create summary routes for directly connected networks, not for routes you learn from other EIGRP routers.”

    i just learned it here.

    thanks rene!

  2. Good to hear you like it! I think that’s one of the things that is important to know, most people assume EIGRP will just summarize anything when you use auto-summary.

  3. Hi Rene
    I got this “EIGRP auto-summary will only create summary routes for directly connected networks, not for routes you learn from other EIGRP routers.”
    But what about OSPF auto-summary route. Does it do the same thing ?
    Thank you so much .

  4. Hi guys,

    so can we say that the auto-summary command is the same for EIGRP and RIP?
    When enabled, routes will be summarized to the class A, B or C network and no mask will be send with the update message?

    Thanks
    Florian

  5. Hello florian

    Essentially, yes, that is correct. However, EIGRP unlike RIP will automatically install a discard route in the local routing table. The discard route is one that has as an exit interface the Null0 interface.

    I hope this has been helpful!

    Laz

8 more replies! Ask a question or join the discussion by visiting our Community Forum