How to configure Frame-Relay Point-to-Point

In previous lessons I gave an introduction about frame-relay and explained how to configure frame-relay point-to-multipoint. In this lesson we’ll take a look at frame-relay point-to-point which is far easier to configure.

Let’s take a look at frame-relay point-to-point. This is the topology that we’ll use:

fr hub spoke dlci numbers

We are using the same topology with one difference. Point-to-point links require an IP Subnet per PVC:

  • Hub and Spoke1: 192.168.12.0 /24
  • Hub and Spoke2: 192.168.13.0 /24
Hub(config)#interface serial 0/0
Hub(config-if)#encapsulation frame-relay

Hub(config)#interface serial 0/0.1 point-to-point
Hub(config-subif)#ip address 192.168.12.1 255.255.255.0
Hub(config-subif)#frame-relay interface-dlci 102

Hub(config)#interface serial 0/0.2 point-to-point
Hub(config-subif)#ip address 192.168.13.1 255.255.255.0
Hub(config-subif)#frame-relay interface-dlci 103
Spoke1(config)#interface s0/0
Spoke1(config-if)#encapsulation frame-relay
Spoke1(config-if)#exit
Spoke1(config)#interface serial 0/0.1 point-to-point
Spoke1(config-subif)#ip address 192.168.12.2 255.255.255.0
Spoke1(config-subif)#frame-relay interface-dlci 201
Spoke2(config)#interface serial 0/0
Spoke2(config-if)#encapsulation frame-relay
Spoke2(config-if)#exit
Spoke2(config)#interface serial 0/0.1 point-to-point
Spoke2(config-subif)#ip address 192.168.13.3 255.255.255.0
Spoke2(config-subif)#frame-relay interface-dlci 301

Here is the configuration for the hub and spoke routers. You only have to specify encapsulation frame-relay on the physical interface. The rest of the commands are on the sub-interfaces. Your router can’t read your mind and find out on which sub-interfaces which DLCI’s should be so you have to configure it yourself. We don’t use the frame-relay map command for point-to-point sub-interfaces but you have to use the frame-relay interface-dlci command here.

Let’s configure RIP:

Hub(config)#router rip      
Hub(config-router)#no auto-summary 
Hub(config-router)#version 2
Hub(config-router)#network 192.168.12.0
Hub(config-router)#network 192.168.13.0
Spoke1(config)#interface loopback 0
Spoke1(config-if)#ip address 2.2.2.2 255.255.255.0
Spoke1(config)#router rip
Spoke1(config-router)#version 2
Spoke1(config-router)#no auto-summary
Spoke1(config-router)#network 192.168.12.0
Spoke1(config-router)#network 2.0.0.0 
Spoke2(config)#router rip
Spoke2(config-router)#version 2
Spoke2(config-router)#no auto-summary 
Spoke2(config-router)#network 192.168.13.0

And let’s see what we have in the routing tables:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You’ve Ever Spent on Your Cisco Career!
  • Full Access to our 743 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

616 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Tags:


Forum Replies

  1. Very Clear. Thanks

  2. superb.now i’m able to understand frame-relay concept because of your doc.
    can you please post the command to make a router as a frame relay switch with point-to-multipoint and point-to-point.

  3. You are welcome. Here’s a quick example for a frame-relay switch:

    frame-relay switching
    
    interface serial0/0
    description DLCI_102_TO_R1
    frame-relay intf-type dce
    frame-relay route 102 interface serial0/1 201
    
    interface serial0/1
    description DLCI_201_TO_R2
    frame-relay intf-type dce
    frame-relay route 201 interface serial0/0 102
    

    This will switch traffic between DLCI 102 and 201

    Best Regards,

    Rene

  4. Thnx Rene for this site,for gns3vault. Your new ccna 200-120 book helped me alot. :slight_smile:

    Regards.

47 more replies! Ask a question or join the discussion by visiting our Community Forum