How to configure OSPF Totally NSSA Area

OSPF has different special area types, I covered these before:

Now it’s time to demonstrate the totally NSSA area. Here is the topology we will use:

ospf stub area

And here’s the configuration. We will turn OSPF Area 1 into a stub area:

R1(config)#router ospf 1
R1(config-router)#network 192.168.12.0 0.0.0.255 area 0
R1(config-router)#redistribute connected subnets
R2(config)#router ospf 1
R2(config-router)#area 1 stub
R2(config-router)#network 192.168.12.0 0.0.0.255 area 0 
R2(config-router)#network 192.168.23.0 0.0.0.255 area 1
R3(config)#router ospf 1
R3(config-router)#area 1 stub
R3(config-router)#network 192.168.23.0 0.0.0.255 area 1

Let’s see what the routing table of R3 looks like:

R3#show ip route ospf 
O IA 192.168.12.0/24 [110/2] via 192.168.23.2, 00:00:42, FastEthernet0/0
O*IA 0.0.0.0/0 [110/2] via 192.168.23.2, 00:00:42, FastEthernet0/0

When we look at R3 you’ll see network 192.168.12.0 /24 and a default route as inter-area (LSA Type 3). Because area 1 is a stub area, we won’t see 1.1.1.0/24 as external type 2 (LSA type 5). First we’ll create a loopback interface on R3 and redistribute it into OSPF to show you the NSSA area.

R3(config)#interface loopback 0
R3(config-if)#ip address 3.3.3.3 255.255.255.0
R3(config-if)#exit
R3(config)#router ospf 1
R3(config-router)#redistribute connected subnets

I’ll add a new loopback interface and try to redistribute it into OSPF on R3, here’s what you’ll see:

R3# %OSPF-4-ASBR_WITHOUT_VALID_AREA: Router is currently an ASBR while having only one area which is a stub area

The stub and totally stub area block LSA Type 5 so it’s impossible to have an ASBR within these areas. First I’ll change area 1 into an NSSA to allow this ASBR:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You’ve Ever Spent on Your Cisco Career!
  • Full Access to our 735 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

512 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Tags: ,


Forum Replies

  1. Hi Rene !

    When you configured the area 1 nssa no-summary you have not configured the same statement in router Susan. Why not ? Its not also necessary? or i am misunderstanding and you have to configured in the ASBR only ?

    You said that we have to configured the area 1 nssa-summary in all the area. So i have that doubt.

    THANKS IN ADVANCE !!

  2. Hi Ieltxu,

    Good question. You have to configure “no-summary” only on the ABR since that’s the router that will inject the default route(s) into the area. No need to do it on all routers in the (totally) NSSA area.

    Rene

  3. Hi Ajith,

    That’s right, it’s the ABR that will block the LSAs from entering the stub or nssa area so that’s the only router where you have to add “no-summary”.

    Rene

  4. Hey Rene,

    First off, I just wanted to say that I really love the pin feature that pins the diagrams to the lower right side of the monitor. It has made studying so much more convenient on your site!

    Anyway, I just wanted to point something out on this lesson. In the passage below:

    “When we look at R3 you’ll see network 192.168.12.0 /24 as inter-area (LSA Type 3) and 1.1.1.0 /24 as external type 2 (LSA Type 5). First we’ll create a loopback interface on R3 and redistribute it into OSPF to show you the NSSA area.”

    I think it should read:

    “When we look at R3 you’l

    ... Continue reading in our forum

  5. Hello Leroy

    Glad to hear that you like the pin feature. We’re always trying to make the site as functional and useful as possible for you to study and get the most out of the content. If you have any suggestions to further improve its functionality, let us know!

    Thanks for pointing this typo out, I will let @ReneMolenaar know to make the correction.

    Thanks again!

    Laz

4 more replies! Ask a question or join the discussion by visiting our Community Forum