BGP Community Local AS

The local AS community is a well known BGP community and can be used for BGP confederations. It’s basically the same as the no export community but this one works for within the sub-AS of a confederation. Prefixes that are tagged are only advertised to other neighbors in the same sub-AS, not to other sub-AS’es or eBGP routers.

Configuration

To demonstrate this I will use the following topology:

Bgp Community Local As Topology

AS 2345 has 4 routers and 2 sub-AS’es. We will advertise a prefix from R1 to AS 2345 so you can see what happens with and without the use of the local AS community. Let’s look at the configuration…

Configurations

Want to take a look for yourself? Here you will find the startup configuration of each device.

R1

hostname R1
!
ip cef
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/1
 ip address 192.168.12.1 255.255.255.0
!
router bgp 1
 bgp log-neighbor-changes
 network 1.1.1.1 mask 255.255.255.255
 neighbor 192.168.12.2 remote-as 2345
!
end

R2

hostname R2
!
ip cef
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/1
 ip address 192.168.12.2 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 192.168.23.2 255.255.255.0
!
interface GigabitEthernet0/3
 ip address 192.168.24.2 255.255.255.0
!
router ospf 1
 network 2.2.2.2 0.0.0.0 area 0
 network 192.168.12.0 0.0.0.255 area 0
 network 192.168.23.0 0.0.0.255 area 0
 network 192.168.24.0 0.0.0.255 area 0
!
router bgp 23
 bgp log-neighbor-changes
 bgp confederation identifier 2345
 bgp confederation peers 45 
 neighbor 3.3.3.3 remote-as 23
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 4.4.4.4 remote-as 45
 neighbor 4.4.4.4 ebgp-multihop 2
 neighbor 4.4.4.4 update-source Loopback0
 neighbor 192.168.12.1 remote-as 1
!
end

R3

hostname R3
!
ip cef
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/1
 ip address 192.168.36.3 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 192.168.23.3 255.255.255.0
!
interface GigabitEthernet0/3
 ip address 192.168.35.3 255.255.255.0
!
router ospf 1
 network 3.3.3.3 0.0.0.0 area 0
 network 192.168.23.0 0.0.0.255 area 0
 network 192.168.35.0 0.0.0.255 area 0
 network 192.168.36.0 0.0.0.255 area 0
!
router bgp 23
 bgp log-neighbor-changes
 bgp confederation identifier 2345
 bgp confederation peers 45 
 neighbor 2.2.2.2 remote-as 23
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 5.5.5.5 remote-as 45
 neighbor 5.5.5.5 ebgp-multihop 2
 neighbor 5.5.5.5 update-source Loopback0
 neighbor 192.168.36.6 remote-as 6
!
end

R4

hostname R4
!
ip cef
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface GigabitEthernet0/1
 ip address 192.168.24.4 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 192.168.45.4 255.255.255.0
!
router ospf 1
 network 4.4.4.4 0.0.0.0 area 0
 network 192.168.24.0 0.0.0.255 area 0
 network 192.168.45.0 0.0.0.255 area 0
!
router bgp 45
 bgp log-neighbor-changes
 bgp confederation identifier 2345
 bgp confederation peers 23 
 neighbor 2.2.2.2 remote-as 23
 neighbor 2.2.2.2 ebgp-multihop 2
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 5.5.5.5 remote-as 45
 neighbor 5.5.5.5 update-source Loopback0
!
end

R5

hostname R5
!
ip cef
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface GigabitEthernet0/1
 ip address 192.168.35.5 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 192.168.45.5 255.255.255.0
!
router ospf 1
 network 5.5.5.5 0.0.0.0 area 0
 network 192.168.35.0 0.0.0.255 area 0
 network 192.168.45.0 0.0.0.255 area 0
!
router bgp 45
 bgp log-neighbor-changes
 bgp confederation identifier 2345
 bgp confederation peers 23 
 neighbor 3.3.3.3 remote-as 23
 neighbor 3.3.3.3 ebgp-multihop 2
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 4.4.4.4 remote-as 45
 neighbor 4.4.4.4 update-source Loopback0
!
end

R6

hostname R6
!
ip cef
!
interface GigabitEthernet0/1
 ip address 192.168.36.6 255.255.255.0
!
router bgp 6
 bgp log-neighbor-changes
 neighbor 192.168.36.3 remote-as 2345
!
end

R1 advertises prefix 1.1.1.1/32 in BGP, let’s see if our routers have learned this:

R2#show ip bgp | begin 1.1.1.1
*> 1.1.1.1/32       192.168.12.1             0             0 1 i
R3#show ip bgp | begin 1.1.1.1
*>i1.1.1.1/32       192.168.12.1             0    100      0 1 i
R4#show ip bgp | begin 1.1.1.1
* i1.1.1.1/32       192.168.12.1             0    100      0 (23) 1 i
*>                  192.168.12.1             0    100      0 (23) 1 i
R5#show ip bgp | begin 1.1.1.1
* i1.1.1.1/32       192.168.12.1             0    100      0 (23) 1 i
*>                  192.168.12.1             0    100      0 (23) 1 i
R6#show ip bgp | begin 1.1.1.1
*> 1.1.1.1/32       192.168.36.3                           0 2345 1 i

All routers know about this prefix. Time to activate the local AS community…

Local AS Community Configuration

We will create a route-map on R2  that sets the local AS community on all prefixes that it receives from R1:

R2(config)#route-map LOCAL_AS permit 10
R2(config-route-map)#set community local-AS 

R2(config)#router bgp 23
R2(config-router)#neighbor 192.168.12.1 route-map LOCAL_AS in
R2(config-router)#neighbor 3.3.3.3 send-community

R2 sets the community so make sure that it advertises it to R3. Before we reset BGP, take a look at the BGP table of R2:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You’ve Ever Spent on Your Cisco Career!
  • Full Access to our 786 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

1514 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Tags:


Forum Replies

  1. Quick question Rene on this topic. The lab works fine as I followed along with my own topology. But I am just wondering why R2 should send the community only to R3? For example, you mentioned: “R2 sets the community so make sure that it advertises it to R3”… why should it not send the community to R4 as well. I know R4 is in another AS, but R4 would have filtered it out as well, wouldn’t it?

  2. Hi Mario,

    On R2 I configured the route-map inbound (facing R1) so that R2 sets the local AS community. Because of this, R2 will no longer advertise prefixes to R4 since it’s another sub-AS. R3 will still receive it since it’s in the same sub-AS as R2.

    To make sure R5 (and R4) learn anything through R3, we need to advertise the local AS community to R3.

    Rene

  3. Hi Rene,

    In your comment you mentioned “To make sure R5 (and R4) learn anything through R3, we need to advertise the local AS community to R3” . How can R3 advertise to R4 and R5 when they in different Sub AS.

    Thanks in advance.

  4. Hi Mohammed,

    You can advertise prefixes from one sub-AS to another sub-AS, that’s no problem.

    Take a look at the BGP Confederations lesson, that might be helpful.

    Rene

23 more replies! Ask a question or join the discussion by visiting our Community Forum