BGP Community Local AS

The local AS community is a well known BGP community and can be used for BGP confederations. It’s basically the same as the no export community but this one works for within the sub-AS of a confederation. Prefixes that are tagged are only advertised to other neighbors in the same sub-AS, not to other sub-AS’es or eBGP routers.

Configuration

To demonstrate this I will use the following topology:

Bgp Community Local As Topology

AS 2345 has 4 routers and 2 sub-AS’es. We will advertise a prefix from R1 to AS 2345 so you can see what happens with and without the use of the local AS community. Let’s look at the configuration…

Configurations

Want to take a look for yourself? Here you will find the startup configuration of each device.

R1

hostname R1
!
ip cef
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/1
 ip address 192.168.12.1 255.255.255.0
!
router bgp 1
 bgp log-neighbor-changes
 network 1.1.1.1 mask 255.255.255.255
 neighbor 192.168.12.2 remote-as 2345
!
end

R2

hostname R2
!
ip cef
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/1
 ip address 192.168.12.2 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 192.168.23.2 255.255.255.0
!
interface GigabitEthernet0/3
 ip address 192.168.24.2 255.255.255.0
!
router ospf 1
 network 2.2.2.2 0.0.0.0 area 0
 network 192.168.12.0 0.0.0.255 area 0
 network 192.168.23.0 0.0.0.255 area 0
 network 192.168.24.0 0.0.0.255 area 0
!
router bgp 23
 bgp log-neighbor-changes
 bgp confederation identifier 2345
 bgp confederation peers 45 
 neighbor 3.3.3.3 remote-as 23
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 4.4.4.4 remote-as 45
 neighbor 4.4.4.4 ebgp-multihop 2
 neighbor 4.4.4.4 update-source Loopback0
 neighbor 192.168.12.1 remote-as 1
!
end

R3

hostname R3
!
ip cef
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/1
 ip address 192.168.36.3 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 192.168.23.3 255.255.255.0
!
interface GigabitEthernet0/3
 ip address 192.168.35.3 255.255.255.0
!
router ospf 1
 network 3.3.3.3 0.0.0.0 area 0
 network 192.168.23.0 0.0.0.255 area 0
 network 192.168.35.0 0.0.0.255 area 0
 network 192.168.36.0 0.0.0.255 area 0
!
router bgp 23
 bgp log-neighbor-changes
 bgp confederation identifier 2345
 bgp confederation peers 45 
 neighbor 2.2.2.2 remote-as 23
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 5.5.5.5 remote-as 45
 neighbor 5.5.5.5 ebgp-multihop 2
 neighbor 5.5.5.5 update-source Loopback0
 neighbor 192.168.36.6 remote-as 6
!
end

R4

hostname R4
!
ip cef
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface GigabitEthernet0/1
 ip address 192.168.24.4 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 192.168.45.4 255.255.255.0
!
router ospf 1
 network 4.4.4.4 0.0.0.0 area 0
 network 192.168.24.0 0.0.0.255 area 0
 network 192.168.45.0 0.0.0.255 area 0
!
router bgp 45
 bgp log-neighbor-changes
 bgp confederation identifier 2345
 bgp confederation peers 23 
 neighbor 2.2.2.2 remote-as 23
 neighbor 2.2.2.2 ebgp-multihop 2
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 5.5.5.5 remote-as 45
 neighbor 5.5.5.5 update-source Loopback0
!
end

R5

hostname R5
!
ip cef
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface GigabitEthernet0/1
 ip address 192.168.35.5 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 192.168.45.5 255.255.255.0
!
router ospf 1
 network 5.5.5.5 0.0.0.0 area 0
 network 192.168.35.0 0.0.0.255 area 0
 network 192.168.45.0 0.0.0.255 area 0
!
router bgp 45
 bgp log-neighbor-changes
 bgp confederation identifier 2345
 bgp confederation peers 23 
 neighbor 3.3.3.3 remote-as 23
 neighbor 3.3.3.3 ebgp-multihop 2
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 4.4.4.4 remote-as 45
 neighbor 4.4.4.4 update-source Loopback0
!
end

R6

hostname R6
!
ip cef
!
interface GigabitEthernet0/1
 ip address 192.168.36.6 255.255.255.0
!
router bgp 6
 bgp log-neighbor-changes
 neighbor 192.168.36.3 remote-as 2345
!
end

R1 advertises prefix 1.1.1.1/32 in BGP, let’s see if our routers have learned this:

R2#show ip bgp | begin 1.1.1.1
*> 1.1.1.1/32       192.168.12.1             0             0 1 i
R3#show ip bgp | begin 1.1.1.1
*>i1.1.1.1/32       192.168.12.1             0    100      0 1 i
R4#show ip bgp | begin 1.1.1.1
* i1.1.1.1/32       192.168.12.1             0    100      0 (23) 1 i
*>                  192.168.12.1             0    100      0 (23) 1 i
R5#show ip bgp | begin 1.1.1.1
* i1.1.1.1/32       192.168.12.1             0    100      0 (23) 1 i
*>                  192.168.12.1             0    100      0 (23) 1 i
R6#show ip bgp | begin 1.1.1.1
*> 1.1.1.1/32       192.168.36.3                           0 2345 1 i

All routers know about this prefix. Time to activate the local AS community…

Local AS Community Configuration

We will create a route-map on R2  that sets the local AS community on all prefixes that it receives from R1:

R2(config)#route-map LOCAL_AS permit 10
R2(config-route-map)#set community local-AS 

R2(config)#router bgp 23
R2(config-router)#neighbor 192.168.12.1 route-map LOCAL_AS in
R2(config-router)#neighbor 3.3.3.3 send-community

R2 sets the community so make sure that it advertises it to R3. Before we reset BGP, take a look at the BGP table of R2:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You've Ever Spent on Your Cisco Career!
  • Full Access to our 657 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

541 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Tags:


Forum Replies

  1. Hi,

    I am confused about BGP selecting path.Here topology

    http://i65.tinypic.com/2r7n9t3.jpg

    R5 is in sub-AS 45.And advertise prefix 9.9.9.9/32.

    R5#sh ip bgp             
    BGP table version is 14, local router ID is 5.5.5.5
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 9.9.9.9/32       0.0.0.0                  0         32768 i
    *> 192.168.12.0     2.2.2.2               
    ... Continue reading in our forum

  2. Hi Ler Sak,

    BGP doesn’t differentiate between confed-internal or confed-external. When the two paths are the same, it’s up to the router ID to decide which one will be selected.

    Here’s an example from the topology I used in this lesson:

    R4#show ip bgp 55.55.55.55/32
    BGP routing table entry for 55.55.55.55/32, version 5
    Paths: (2 available, best #1, table default)
    Flag: 0x800
      Not advertised to any peer
      Refresh Epoch 1
      (35)
        5.5.5.5 (metric 2) from 2.2.2.2 (2.2.2.2)
          Origin IGP, metric 0, localpref 100, valid, confed-internal, best
          rx pathid: 
    ... Continue reading in our forum

  3. Hello,

    Just a few remarks/questions for this lesson.

    I believe R2 should advertise the 192.168.12.0/24 network (network 192.168.12.0 mask 255.255.255.0), otherwise the other routers will not know about 192.168.12.1 as next-hop for 1.1.1.1 (I checked the confederations lesson).
    Also on R3 the neighbor command for R6 should be .2 instead of .6.

    One question is how will R5 select the path towards 1.1.1.1? In your previous post I saw that Router ID is selected, but shouldn’t be attribute 7 (eBGP path over iBGP path)?. I believe that confed-external behaves like eBG

    ... Continue reading in our forum

  4. Hello Stefanita,

    I just made some changes to this lesson:

    I fixed this in the topology picture.

    ... Continue reading in our forum

  5. Hello Rene,

    Can the local-as community be configured only by the router receiving the traffic, just like the MED and AS-Path prepending attributes?

    Thanks

    William

9 more replies! Ask a question or join the discussion by visiting our Community Forum