How to configure IPv6 EIGRP on Cisco IOS Router

Cisco’s EIGRP is one of the routing protocols that is suitable for IPv6. Configuration is a bit different and in this lesson I’ll demonstrate to you how to configure it. This is the topology we’ll use:

R1 R2 IPv6 addresses on loopback interfaces

Note that I don’t have any global unicast IPv6 addresses on the FastEthernet interface because the EIGRP updates will be sent using the link-local addresses.

Configuration

First we will enable routing for IPv6:

R1 & R2
(config)#ipv6 unicast-routing

And let’s configure some IPv6 addresses:

R1 & R2
(config)#interface GigabitEthernet 0/1
(config-if)#ipv6 enable 
R1(config)#interface loopback 0
R1(config-if)#ipv6 address 2001::1/128
R2(config)#interface loopback 0
R2(config-if)#ipv6 address 2001::2/128

Enabling IPv6 on the Gigabit interfaces will generate an IPv6 link local address. The loopback interfaces will have a global unicast address. Let’s verify our work:

R1#show ipv6 interface brief
GigabitEthernet0/1     [up/up]
    FE80::F816:3EFF:FE7B:61CA
Loopback0              [up/up]
    FE80::F816:3EFF:FEC5:1BD7
    2001::1
R2#show ipv6 interface brief 
GigabitEthernet0/1     [up/up]
    FE80::F816:3EFF:FE8F:4F66
Loopback0              [up/up]
    FE80::F816:3EFF:FED1:4100
    2001::2

After configuring the IPv6 addresses on the loopback interface you can see the global unicast and the link-local IPv6 addresses.

This is how you enable EIGRP for IPv6:

R1(config)#ipv6 router eigrp 1
R1(config-rtr)#router-id 1.1.1.1
R1(config-rtr)#no shutdown

R1(config)#interface GigabitEthernet 0/1
R1(config-if)#ipv6 eigrp 1

R1(config)#interface loopback 0
R1(config-if)#ipv6 eigrp 1
R2(config)#ipv6 router eigrp 1
R2(config-rtr)#router-id 2.2.2.2
R2(config-rtr)#no shutdown

R2(config)#interface GigabitEthernet 0/1
R2(config-if)#ipv6 eigrp 1

R2(config)#interface loopback 0
R2(config-if)#ipv6 eigrp 1

First, you need to start EIGRP with the ipv6 router eigrp command. The number you see is the autonomous system number and it has to match on both routers. Each EIGRP router needs a router ID which is the highest IPv4 address on the router.

If you don’t have any IPv4 addresses you need to specify it yourself with the router-id command. By default, the EIGRP process is in shutdown mode and you need to type no shutdown to activate it.

Last step is to enable it on the interfaces with the ipv6 eigrp command. Let’s verify our configuration:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You've Ever Spent on Your Cisco Career!
  • Full Access to our 654 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

540 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Forum Replies

  1. easy to understand! thanks!
    just fyi, i simulate it on GNS3, using 7200 15.2ios. under ipv6 router eigrp 1, theres no “router-id” command, you need to go “eigrp router-id 1.1.1.1”

  2. I also did this lab and just as the first poster stated there is no Router-ID command.

    note I tested this on the newest cisco VIRL IOS that I have imported into GNS3 and I also tested on the 7200 model. So neither of the routers can use this command. this means it must be something legacy or a typo. also the 7200 gns3 image is quite a bit older than the newer cisco VIRL image that both did not work says this has probably not been an option for a while.

    ===================================EDITED==================================================

    I did go bac

    ... Continue reading in our forum

  3. EIGRP was sending HELLOs only on my Loopback0 interface despite “ipv6 enable” on my FastEthernet interface. Neighbor adjacency was formed only after adding a global unicast IP on my FastEthernet interface connecting my routers.

    Rohan

  4. Hi,
    It would be great to add EIGRP v6 in named mode in here as well…thanks.

4 more replies! Ask a question or join the discussion by visiting our Community Forum