EIGRP Summary Leak Map

Lesson Contents

When you configure an EIGRP summary route, all networks that fall within the range of your summary are suppressed and no longer advertised on the interface. Only the summary route is advertised.

What if you still want to advertise a network separately next to your summary route? This can be useful for traffic engineering. Luckily, this is possible with the summary leak-map. Let’s have a look…

Configuration

To demonstrate the summary leak-map, I will use three routers:

eigrp summary leak map topology

R1 has two loopback interfaces: 192.168.0.1/24 and 192.168.1.1/24. We are going to summarize these two networks.







Let’s start with a basic EIGRP configuration that advertises all interfaces:

R1#show run | begin router eigrp
router eigrp 1
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.12.0
 network 192.168.13.0
R2#show run | begin router eigrp
router eigrp 1
 network 192.168.12.0
 network 192.168.23.0
R3#show run | begin router eigrp
router eigrp 1
 network 192.168.13.0
 network 192.168.23.0

Let’s create a summary route for 192.168.0.0/24 and 192.168.1.0/24 and advertise it on both interfaces on R1:

R1(config)#interface GigabitEthernet 0/1
R1(config-if)#ip summary-address eigrp 1 192.168.0.0/23

R1(config)#interface GigabitEthernet 0/2
R1(config-if)#ip summary-address eigrp 1 192.168.0.0/23 

Here are the routing tables of R2 and R3:

R2#show ip route eigrp               

D     192.168.0.0/23 
           [90/130816] via 192.168.12.1, 00:01:10, GigabitEthernet0/1
D     192.168.13.0/24 [90/3072] via 192.168.23.3, 00:06:59, GigabitEthernet0/2
                      [90/3072] via 192.168.12.1, 00:06:59, GigabitEthernet0/1
R3#show ip route eigrp 

D     192.168.0.0/23 
           [90/130816] via 192.168.13.1, 00:01:00, GigabitEthernet0/2
D     192.168.12.0/24 [90/3072] via 192.168.23.2, 00:06:49, GigabitEthernet0/1
                      [90/3072] via 192.168.13.1, 00:06:49, GigabitEthernet0/2

R2 and R3 don’t have any specific network entries for the loopback interfaces of R1, only a summary route.

What if I wanted R3 to use R2 to reach 192.168.0.1/24? Right now this is impossible because R3 is using its summary route.

What we can do, however, is use a leak-map on the summary that we advertise to R2 and advertise 192.168.0.0/24 separately. R2 will then advertise it to R3. With a more specific route, R3 will prefer R2 to get to 192.168.0.0/24.

Here’s how to do this:

R1(config)#ip access-list standard L0
R1(config-std-nacl)#permit 192.168.0.0 0.0.0.255

R1(config)#route-map L0_LEAK permit 10
R1(config-route-map)#match ip address L0

First, we create an access-list that matches 192.168.0.0/24 and then a new route-map that refers to the access-list.

Now we change our summary command so that it includes the route-map:

R1(config)#interface GigabitEthernet 0/1
R1(config-if)#ip summary-address eigrp 1 192.168.0.0/23 leak-map L0_LEAK

Let’s see how this affects the routing tables of R2 and R3:

R2#show ip route eigrp 

D     192.168.0.0/23 
           [90/130816] via 192.168.12.1, 00:03:54, GigabitEthernet0/1
D     192.168.0.0/24 
           [90/130816] via 192.168.12.1, 00:00:24, GigabitEthernet0/1
D     192.168.13.0/24 [90/3072] via 192.168.23.3, 00:09:43, GigabitEthernet0/2
                      [90/3072] via 192.168.12.1, 00:09:43, GigabitEthernet0/1

As you can see above, R2 now has a summary route and a specific entry for 192.168.0.0/24. Both use R1 as the next hop so it doesn’t affect R2. Let’s take a look at R3:

R3#show ip route eigrp 

D     192.168.0.0/23 
           [90/130816] via 192.168.13.1, 00:04:00, GigabitEthernet0/2
D     192.168.0.0/24 
           [90/131072] via 192.168.23.2, 00:00:30, GigabitEthernet0/1
D     192.168.12.0/24 [90/3072] via 192.168.23.2, 00:09:49, GigabitEthernet0/1
                      [90/3072] via 192.168.13.1, 00:09:49, GigabitEthernet0/2

R3 still has the summary route it learned on its GigabitEthernet 0/2 interface but also learns the 192.168.0.0/24 network from R2. Since this is a more specific route, R3 will use R2 to get to 192.168.0.0/24:

R3#show ip route 192.168.0.1
Routing entry for 192.168.0.0/24
  Known via "eigrp 1", distance 90, metric 131072, type internal
  Redistributing via eigrp 1
  Last update from 192.168.23.2 on GigabitEthernet0/1, 00:01:42 ago
  Routing Descriptor Blocks:
  * 192.168.23.2, from 192.168.23.2, 00:01:42 ago, via GigabitEthernet0/1
      Route metric is 131072, traffic share count is 1
      Total delay is 5020 microseconds, minimum bandwidth is 1000000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2

And here’s the summary route that R3 uses to get to 192.168.1.0/24:

R3#show ip route 192.168.1.1
Routing entry for 192.168.0.0/23, supernet
  Known via "eigrp 1", distance 90, metric 130816, type internal
  Redistributing via eigrp 1
  Last update from 192.168.13.1 on GigabitEthernet0/2, 00:05:07 ago
  Routing Descriptor Blocks:
  * 192.168.13.1, from 192.168.13.1, 00:05:07 ago, via GigabitEthernet0/2
      Route metric is 130816, traffic share count is 1
      Total delay is 5010 microseconds, minimum bandwidth is 1000000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1

That’s all there is to it.

Configurations

Want to take a look for yourself? Here you will find the final configuration of each device.

R1

hostname R1
!
ip cef
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.0
!
interface Loopback1
 ip address 192.168.1.1 255.255.255.0
!
interface GigabitEthernet0/1
 ip address 192.168.12.1 255.255.255.0
 ip summary-address eigrp 1 192.168.0.0 255.255.254.0 leak-map L0_LEAK
!
interface GigabitEthernet0/2
 ip address 192.168.13.1 255.255.255.0
 ip summary-address eigrp 1 192.168.0.0 255.255.254.0
!
router eigrp 1
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.12.0
 network 192.168.13.0
!
ip access-list standard L0
 permit 192.168.0.0 0.0.0.255
!
route-map L0_LEAK permit 10
 match ip address L0
!
end

R2

hostname R2
!
ip cef
!
interface GigabitEthernet0/1
 ip address 192.168.12.2 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 192.168.23.2 255.255.255.0
!
router eigrp 1
 network 192.168.12.0
 network 192.168.23.0
!
end

R3

hostname R3
!
ip cef
!
interface GigabitEthernet0/1
 ip address 192.168.23.3 255.255.255.0
!
interface GigabitEthernet0/2
 ip address 192.168.13.3 255.255.255.0
!
router eigrp 1
 network 192.168.13.0
 network 192.168.23.0
!
end

Conclusion

You have now learned how to use the leak-map to advertise specific networks next to a summary route thanks to the EIGRP summary leak-map feature. You have also learned how you can use this feature for traffic engineering.

Tags:


Forum Replies

  1. Hello Joseph

    The metric will play a role only when comparing the exact same entries in the routing table. 192.168.0.0/23 and 192.168.0.0/24 are two different routing entries and thus each one has its own metric.

    If they were the same and had a different metric, only one of them would end up in the routing table, so you would have no problem choosing which one to use. (Unless of course you use unequal cost load balancing for EIGRP, but that’s a different story.)

    The first step when going through the routing table is to get the closest match of the destination

    ... Continue reading in our forum

  2. Excellent, I’ve got it now, thanks Laz!

Ask a question or join the discussion by visiting our Community Forum