We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is Why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You've Ever Spent on Your Cisco Career!
  • Full Access to our 641 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

 

391 New Members signed up the last 30 days!

satisfaction-guaranteed

100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Tags: ,


Forum Replies

  1. Hi This is an excellent article.

    But I have one quesion.

    HUBs
    ip nhrp network-id 1
    
    SPOkES
    ip nhrp network-id 2
    

    Is it Ok that HUBs and SPOKEs network-id is different?

  2. Very useful lesson.

    Thanks Rene.

    I think below can be control the route also

    For OSPF, if the Hub network is redistributed will be easy as Hub 1 can advertised as E1 and Hub 2 advertised as E2.

    For EIGRP, Hub2 also can use AD or Metric to manipulate the route for Spoke.

    Davis

  3. Hi Davis,

    You could use redistribution to influence how the spoke routers reach R1 on top. Hub1 could advertise regular OSPF routes and hub2 could redistribute these routes.

    Getting from the hubs to the spoke routers is harded though, the spoke routes are advertising the same info to both hub routers.

    EIGRP is a bit more flexible than OSPF.

    Rene

  4. Hi Rene,
    Actually, I’m building a DMVPN lab 2 hubs and spokes. the 2 hubs is located in different subnets as follows :
    Hub01 :

    
    interface Tunnel0
     ip address 172.16.253.1 255.255.255.0
     no ip redirects
     ip nhrp authentication DMVPN
     ip nhrp map multicast dynamic
     ip nhrp network-id 1
     tunnel source GigabitEthernet0
     tunnel mode gre multipoint
     !
    end
    
    

    Hub02 :

    
    interface Tunnel0
     ip address 172.16.254.1 255.255.255.0
     no ip redirects
     ip nhrp authentication DMVPN
     ip nhrp map multicast dynamic
     ip nhrp network-id 2
     tunnel source GigabitEthernet0
     tunnel mode gr
    ... Continue reading in our forum

  5. Hi Soufiane,

    EIGRP will produce this error when you have two devices on the same segment, sending hello packets to each other but using different subnets. Any chance your spoke routers are connecting to the wrong hub / using the wrong tunnel? Without EIGRP, are you able to ping the tunnel interfaces?

    You might want to compare my configs with yours, you should be able to load mine (with EIGRP) and run those without any errors.

    Rene

7 more replies! Ask a question or join the discussion by visiting our Community Forum