DMVPN Phase 1 EIGRP Routing

In the first DMVPN lesson we discussed the basics and the three different phases. I also showed you how to create a basic DMVPN phase 1 configuration. In this lesson we’ll use that basic configuration and configure EIGRP on top of it. Here’s the topology we will use:

DMVPN Example Topology with hub, two spokes and loopback interfaces.

Each router has a loopback interface with an IP address that we’ll advertise in EIGRP.

Configuration

In the first DMVPN lesson we discussed the basics and the three different phases. I also showed you how to create a basic DMVPN phase 1 configuration. In this lesson we'll use that basic configuration and configure EIGRP on top of it. Here's the topology we will use: Each router has a loopback inter


Tunnel interfaces

Here is the tunnel configuration of the hub and spoke routers:

Hub(config)#interface Tunnel0
Hub(config-if)#ip address 172.16.123.1 255.255.255.0
Hub(config-if)#ip nhrp authentication DMVPN
Hub(config-if)#ip nhrp map multicast dynamic
Hub(config-if)#ip nhrp network-id 1
Hub(config-if)#tunnel source GigabitEthernet0/1
Hub(config-if)#tunnel mode gre multipoint
Spoke1(config)#interface Tunnel0
Spoke1(config-if)#ip address 172.16.123.2 255.255.255.0
Spoke1(config-if)#ip nhrp authentication DMVPN
Spoke1(config-if)#ip nhrp map 172.16.123.1 192.168.123.1
Spoke1(config-if)#ip nhrp map multicast 192.168.123.1
Spoke1(config-if)#ip nhrp network-id 1
Spoke1(config-if)#ip nhrp nhs 172.16.123.1
Spoke1(config-if)#tunnel source GigabitEthernet0/1
Spoke1(config-if)#tunnel destination 192.168.123.1
Spoke2(config)#interface Tunnel0
Spoke2(config-if)#ip address 172.16.123.3 255.255.255.0
Spoke2(config-if)#ip nhrp authentication DMVPN
Spoke2(config-if)#ip nhrp map 172.16.123.1 192.168.123.1
Spoke2(config-if)#ip nhrp map multicast 192.168.123.1
Spoke2(config-if)#ip nhrp network-id 1
Spoke2(config-if)#ip nhrp nhs 172.16.123.1
Spoke2(config-if)#tunnel source GigabitEthernet0/1
Spoke2(config-if)#tunnel destination 192.168.123.1

Let’s do some quick checks to verify that the tunnels are working correctly:

Hub#show dmvpn | begin 192.168.123.
     1 192.168.123.2      172.16.123.2    UP 00:22:37     D
     1 192.168.123.3      172.16.123.3    UP 00:00:32     D

We see two NHRP registrations on the hub, let’s do a quick ping:

Hub#ping 172.16.123.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 6/6/8 ms
Hub#ping 172.16.123.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/6/9 ms

No issues here…let’s configure EIGRP.

EIGRP

Let’s advertise all networks:

Hub(config)#router eigrp 123
Hub(config-router)#network 1.1.1.1 0.0.0.0
Hub(config-router)#network 172.16.123.0 0.0.0.255
Hub(config-router)#no auto-summary 
Spoke1(config)#router eigrp 123
Spoke1(config-router)#network 172.16.123.0 0.0.0.255 
Spoke1(config-router)#network 2.2.2.2 0.0.0.0
Spoke1(config-router)#no auto-summary
Spoke2(config)#router eigrp 123
Spoke2(config-router)#network 172.16.123.0 0.0.0.255
Spoke2(config-router)#network 3.3.3.3 0.0.0.0
Spoke2(config-router)#no auto-summary 

Let’s make sure we see two neighbors on the hub:

Hub#show ip eigrp neighbors 
EIGRP-IPv4 Neighbors for AS(123)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   172.16.123.3            Tu0                      11 00:00:31   13  1434  0  4
0   172.16.123.2            Tu0                      13 00:01:02   82  1434  0  4

So far so good, let’s check our routing tables:

Hub#show ip route eigrp 

      2.0.0.0/32 is subnetted, 1 subnets
D        2.2.2.2 [90/27008000] via 172.16.123.2, 00:01:16, Tunnel0
      3.0.0.0/32 is subnetted, 1 subnets
D        3.3.3.3 [90/27008000] via 172.16.123.3, 00:00:48, Tunnel0

The hub router has two entries, the next hop IP addresses are the tunnel addresses of spoke 1 and 2. When we want to resolve them, we’ll have to check the information in the NHRP cache:

Hub#show dmvpn | begin Hub
Type:Hub, NHRP Peers:2, </code>

# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
1 192.168.123.2 172.16.123.2 UP 00:30:11 D
1 192.168.123.3 172.16.123.3 UP 00:21:28 D

This is how the hub is able to reach both spoke routers. What about the spoke routers?

Spoke1#show ip route eigrp 

      1.0.0.0/32 is subnetted, 1 subnets
D        1.1.1.1 [90/27008000] via 172.16.123.1, 00:01:27, Tunnel0
Spoke2#show ip route eigrp 

      1.0.0.0/32 is subnetted, 1 subnets
D        1.1.1.1 [90/27008000] via 172.16.123.1, 00:01:01, Tunnel0

Like RIP, EIGRP is a distance vector routing protocol so we have split horizon issues. The spoke routers don’t see each other’s networks. Let’s fix this for now:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You've Ever Spent on Your Cisco Career!
  • Full Access to our 654 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

535 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Tags: , ,


Forum Replies

  1. Hi Rene,

    First thanks a lot for all that great work you are doing :-).

    I have a drama going on right now and I could not isolate the root cause of the problem.

    Symptoms:

    on my Hub the GRE Tunnel interface stat UP/Down - I am using cisco appliances running Version 12.2(8r).
    Can you please help ?

    -----
    Router_1#show ip inter br
    Interface IP-Address OK? Method Status Protocol
    FastEthernet0/0 unassigned YES TFTP up down
    Serial0/0 unassigned YES NVRAM administratively do

    ... Continue reading in our forum

  2. Hi Rene,
    Could you please check the exact cause of this error. getting following error in spoke router.

    *Dec 14 11:56:50.720: %DUAL-5-NBRCHANGE: EIGRP-IPv4 45678: Neighbor 123.20.1.25 (Tunnel0) is down: Peer Termination received
    *Dec 14 11:56:54.320: %DUAL-5-NBRCHANGE: EIGRP-IPv4 45678: Neighbor 123.20.1.25 (Tunnel0) is up: new adjacency
    *Dec 14 11:56:54.364: %ADJ-5-PARENT: Midchain parent maintenance for IP midchain out of Tunnel0, addr 123.20.1.25 - looped chain attempting to stack”
    

    Topology:
    Hub-----------------------ISP(AS20003)------------------------Spok

    ... Continue reading in our forum

  3. Hi Abdus,

    This message:

    %ADJ-5-PARENT: Midchain parent maintenance for IP midchain out of Tunnel0

    Is usually a recursive routing issue. Your router is probably learning the NBMA address through the tunnel interface, which is why it collapses.

  4. Hello Mohammed

    In this lab EIGRP is being used as the routing protocol. EIGRP uses a composite metric that is represented by a 32 bit number, which means the metric can range up to 2^32 which is somewhere beyond 4.2 billion. So a metric of 27008000 is not at all unusual.

    To see a more comprehensive explanation of the EIGRP metric and how it is calculated, take a look at this lesson.

    ... Continue reading in our forum

9 more replies! Ask a question or join the discussion by visiting our Community Forum