DMVPN Phase 1 RIP Routing

In the first DMVPN lesson I explained some of its basics, in the second lesson I explained how to create a basic DMVPN phase 1 configuration. In this lesson, we’ll take a look how RIP behaves on DMVPN phase 1.

Here’s the topology we will use:

DMVPN Example Topology loopbacks

Above we have two spoke routers and one hub, our underlay network uses 192.168.123.0/24 and the overlay network uses 172.16.123.0/24. Each router has a loopback interface with a network that we can advertise in RIP.

Configuration

In the first DMVPN lesson I explained some of its basics, in the second lesson I explained how to create a basic DMVPN phase 1 configuration. In this lesson, we'll take a look how RIP behaves on DMVPN phase 1. Here's the topology we will use: Above we have two spoke routers and one hub, our underlay


Tunnel Interfaces

Here is the configuration of the tunnel interfaces on the hub and spoke routers. I explained these commands in the DMVPN phase 1 basic configuration lesson so I’m not going to discuss them again:

Hub(config)#interface Tunnel0
Hub(config-if)#ip address 172.16.123.1 255.255.255.0
Hub(config-if)#ip nhrp authentication DMVPN
Hub(config-if)#ip nhrp map multicast dynamic
Hub(config-if)#ip nhrp network-id 1
Hub(config-if)#tunnel source GigabitEthernet0/1
Hub(config-if)#tunnel mode gre multipoint
Spoke1(config)#interface Tunnel0
Spoke1(config-if)#ip address 172.16.123.2 255.255.255.0
Spoke1(config-if)#ip nhrp authentication DMVPN
Spoke1(config-if)#ip nhrp map 172.16.123.1 192.168.123.1
Spoke1(config-if)#ip nhrp map multicast 192.168.123.1
Spoke1(config-if)#ip nhrp network-id 1
Spoke1(config-if)#ip nhrp nhs 172.16.123.1
Spoke1(config-if)#tunnel source GigabitEthernet0/1
Spoke1(config-if)#tunnel destination 192.168.123.1
Spoke2(config)#interface Tunnel0
Spoke2(config-if)#ip address 172.16.123.3 255.255.255.0
Spoke2(config-if)#ip nhrp authentication DMVPN
Spoke2(config-if)#ip nhrp map 172.16.123.1 192.168.123.1
Spoke2(config-if)#ip nhrp map multicast 192.168.123.1
Spoke2(config-if)#ip nhrp network-id 1
Spoke2(config-if)#ip nhrp nhs 172.16.123.1
Spoke2(config-if)#tunnel source GigabitEthernet0/1
Spoke2(config-if)#tunnel destination 192.168.123.1

Let’s do two quick checks, we want to make sure that both spokes are registered to the hub:

Hub#show dmvpn | begin 192.168.123.
     1 192.168.123.2      172.16.123.2    UP 00:22:37     D
     1 192.168.123.3      172.16.123.3    UP 00:00:32     D

And we want to make sure that we can ping all tunnel IP addresses:

Hub#ping 172.16.123.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 6/6/8 ms
Hub#ping 172.16.123.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/6/9 ms

Now we can focus on the RIP configuration…

RIP

Let’s enable RIP on all routers:

Hub(config)#router rip
Hub(config-router)#version 2
Hub(config-router)#network 1.0.0.0
Hub(config-router)#network 172.16.0.0
Hub(config-router)#no auto-summary
Spoke1(config)#router rip
Spoke1(config-router)#version 2
Spoke1(config-router)#network 2.0.0.0 
Spoke1(config-router)#network 172.16.0.0
Spoke1(config-router)#no auto-summary
Spoke2(config)#router rip
Spoke2(config-router)#version 2
Spoke2(config-router)#network 3.0.0.0
Spoke2(config-router)#network 172.16.0.0 
Spoke2(config-router)#no auto-summary 

Now let’s see what we have…

Hub#show ip route rip 

      2.0.0.0/32 is subnetted, 1 subnets
R        2.2.2.2 [120/1] via 172.16.123.2, 00:00:07, Tunnel0
      3.0.0.0/32 is subnetted, 1 subnets
R        3.3.3.3 [120/1] via 172.16.123.3, 00:00:06, Tunnel0

Our hub router has learned both networks on the loopback interfaces. Take a good look at the next hop IP addresses that we have here, these are the tunnel addresses. When the hub wants to reach these networks, it will have to check NHRP to find the NBMA addresses:

Hub#show dmvpn | begin Hub
Type:Hub, NHRP Peers:2, 

 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
 ----- --------------- --------------- ----- -------- -----
     1 192.168.123.2      172.16.123.2    UP 00:29:29     D
     1 192.168.123.3      172.16.123.3    UP 00:07:24     D

When we want to reach 2.2.2.2/2 we will use 172.16.123.2 as the next hop. In our NHRP cache we see that we need to use NBMA address 192.168.123.2 to get there.

What about the spoke routers, did they learn anything?

Spoke1#show ip route rip 

      1.0.0.0/32 is subnetted, 1 subnets
R        1.1.1.1 [120/1] via 172.16.123.1, 00:00:17, Tunnel0
Spoke2#show ip route rip 

      1.0.0.0/32 is subnetted, 1 subnets
R        1.1.1.1 [120/1] via 172.16.123.1, 00:00:08, Tunnel0

Our spoke routers only have one entry, the network on the loopback interface of the hub router. What went wrong here?

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You've Ever Spent on Your Cisco Career!
  • Full Access to our 654 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

533 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Tags: , ,


Forum Replies

  1. Hi Rene,
    So we call DMVPN is Dynamic mGRE alternatively , rignt ??

    One more confusion regarding the output …

    Spoke1#show ip route rip 
    
          1.0.0.0/32 is subnetted, 1 subnets
    R        1.1.1.1 [120/1] via 172.16.123.1, 00:00:10, Tunnel0
          3.0.0.0/32 is subnetted, 1 subnets
    R        3.3.3.3 [120/2] via 172.16.123.3, 00:00:10, Tunnel0
    

    when Spoke1 want to reach Spoke2(3.3.3.3) , what will be next hop in DMVPN Phase 1 ?? . Its showing 172.16.123.3 but all traffic will go through HUB, right ?Thanks

    br//
    zaman

  2. I realised at least on my lab that using the command “ip summary address rip 0.0.0.0 0.0.0.0” does not inject a default route on the spokes, you also have to include the command “default-information originate” under the “router rip” for this to take effect.

  3. Hello Tariq

    It seems that others are having similar issues with the ip summary address command when using the RIP protocol. Even so, the solution is not the default-information originate command.

    These two commands do different things.

    Default-information originate will advertise default route, while ip summary-address rip 0.0.0.0 0.0.0.0 will advertise only default route and will hide topology details. Remember that the ip summary-address command can use a more specific route, such as ip summary-address rip 10.2.0.0 255.255.0.0, it does not have to be 0.0.0

    ... Continue reading in our forum

  4. Hello Laz,

    Thank you for the feedback, however I decided to simulate again with a vIOS and I received the summary-address as expected, so I guess the issue might be a bug on the initial IOS I was using which was the IOS 15.2 on a 7200.

    regards,

    Tariq

19 more replies! Ask a question or join the discussion by visiting our Community Forum