How to configure Frame-Relay Point-to-Point

In previous lessons I gave an introduction about frame-relay and explained how to configure frame-relay point-to-multipoint. In this lesson we’ll take a look at frame-relay point-to-point which is far easier to configure.

Let’s take a look at frame-relay point-to-point. This is the topology that we’ll use:

fr hub spoke dlci numbers

We are using the same topology with one difference. Point-to-point links require an IP Subnet per PVC:

  • Hub and Spoke1: 192.168.12.0 /24
  • Hub and Spoke2: 192.168.13.0 /24
Hub(config)#interface serial 0/0
Hub(config-if)#encapsulation frame-relay

Hub(config)#interface serial 0/0.1 point-to-point
Hub(config-subif)#ip address 192.168.12.1 255.255.255.0
Hub(config-subif)#frame-relay interface-dlci 102

Hub(config)#interface serial 0/0.2 point-to-point
Hub(config-subif)#ip address 192.168.13.1 255.255.255.0
Hub(config-subif)#frame-relay interface-dlci 103
Spoke1(config)#interface s0/0
Spoke1(config-if)#encapsulation frame-relay
Spoke1(config-if)#exit
Spoke1(config)#interface serial 0/0.1 point-to-point
Spoke1(config-subif)#ip address 192.168.12.2 255.255.255.0
Spoke1(config-subif)#frame-relay interface-dlci 201
Spoke2(config)#interface serial 0/0
Spoke2(config-if)#encapsulation frame-relay
Spoke2(config-if)#exit
Spoke2(config)#interface serial 0/0.1 point-to-point
Spoke2(config-subif)#ip address 192.168.13.3 255.255.255.0
Spoke2(config-subif)#frame-relay interface-dlci 301

Here is the configuration for the hub and spoke routers. You only have to specify encapsulation frame-relay on the physical interface. The rest of the commands are on the sub-interfaces. Your router can’t read your mind and find out on which sub-interfaces which DLCI’s should be so you have to configure it yourself. We don’t use the frame-relay map command for point-to-point sub-interfaces but you have to use the frame-relay interface-dlci command here.

Let’s configure RIP:

Hub(config)#router rip      
Hub(config-router)#no auto-summary 
Hub(config-router)#version 2
Hub(config-router)#network 192.168.12.0
Hub(config-router)#network 192.168.13.0
Spoke1(config)#interface loopback 0
Spoke1(config-if)#ip address 2.2.2.2 255.255.255.0
Spoke1(config)#router rip
Spoke1(config-router)#version 2
Spoke1(config-router)#no auto-summary
Spoke1(config-router)#network 192.168.12.0
Spoke1(config-router)#network 2.0.0.0 
Spoke2(config)#router rip
Spoke2(config-router)#version 2
Spoke2(config-router)#no auto-summary 
Spoke2(config-router)#network 192.168.13.0

And let’s see what we have in the routing tables:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You've Ever Spent on Your Cisco Career!
  • Full Access to our 651 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

555 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Forum Replies

  1. Hello Sims

    There are a couple of options for creating a frame relay topology.

    If you have multiple sites, you can place all routers from all the sites on one subnet like so:

    //cdn-forum.networklessons.com/uploads/default/original/1X/37c0c5f91715589920e6bf6720b3e76372900846.png

    Notice that all serial interfaces are on the same subnet of 10.1.1.0/24. This topology does not require a separate subnet for each link, but one subnet for all routers. This requires the employment of a static frame relay map to map between a next hop protocol address and a DLCI destina

    ... Continue reading in our forum

  2. Hello Rene, I am having issue to set up ospf on my frame relay in GNS3. Below is my configs and topology:

    //cdn-forum.networklessons.com/uploads/default/original/2X/3/3af44434da338fde3d2b53b3107e10aa8e4b2dfe.jpeg

    HQ#show run int s2/0
    Building configuration...
    
    Current configuration : 263 bytes
    !
    interface Serial2/0
     ip address 192.168.123.1 255.255.255.0
     encapsulation frame-relay
     ip ospf 1 area 0
     serial restart-delay 0
     frame-relay map ip 192.168.123.3 103 broadcast
     frame-relay map ip 192.168.123.2 102 broadcast
     no frame-relay inverse-arp
     !
    end
    
    HQ#show i
    ... Continue reading in our forum

  3. Hello sales2161

    Frame-relay can be tricky when implemented with OSPF. Can you tell us a little bit more about your configuration? Please specify in more detail the problem that you’re facing so that we can address it more effectively.

    Thanks!

    Laz

  4. Hello sales2161

    If you look at this lesson, you will find information concerning the implementation of OSPF in a frame relay environment:

    https://networklessons.com/ospf/ospf-broadcast-network-type-over-frame-relay

    Now based on your configuration, what I do see immediately is that in your frame relay interfaces, you are missing the ip ospf network broadcast command. This changes the default OSPF network type to allow for broadcasts to be sent over non broadcast topologies such as frame relay and to allow them to create OSPF adjacencies.

    Take a look at the les

    ... Continue reading in our forum

  5. Hello sales2161

    In order for OSPF to function, you require the broadcast keyword for both the frame-relay map command and the ip ospf network command. If you don’t do this, you can always make OSPF work by manually configuring the neighbors.

    I hope this has been helpful!

    Laz

33 more replies! Ask a question or join the discussion by visiting our Community Forum