Cisco Switch Etherchannel to Synology NAS

In this tutorial I want to show you how to configure an Etherchannel between your Cisco Catalyst Switch and a Synology NAS device. I’m using a Cisco 3560X switch and a Synology DS812+ rackstation that has two gigabit interfaces. The Synology NAS and the Cisco switch both support LACP (Link Aggregation Control Protocol).

Here’s what it looks like:

Synology NAS Connected to Cisco Switch

Configure LACP on Synology NAS

My Synology is connected to Gigabit 0/37 and 0/38 on the Cisco switch. First we’ll configure the Synology NAS. Log into your NAS and open the control panel, select Network.

Synology DSM Control Panel

Select the Network Interface tab and click on Create.

Synology DSM Network Interfaces

Select IEEE 802.3ad Dynamic Link Aggregation and click Next.

Synology DSM Link Aggregation

Select the interfaces that you want to use for the Etherchannel. I only have two Gigabit interfaces so I’ll select both. Click Next to continue.

Synology DSM Select Link Aggregation Interfaces

Last step is to configure your IP address. I don’t have to make any changes so just click Apply to continue.

Synology DSM Link Aggregation IP Address

Your Synology NAS is now ready for LACP. We still have to configure the Cisco switch however…

Configure LACP on Cisco Switch

Let’s configure the Gi0/37 and Gi0/38 interface as an Etherchannel using the LACP protocol:

CISCO(config)#interface range Gi0/37 - 38
CISCO(config-if-range)#description SYNOLOGY
CISCO(config-if-range)#switchport mode access
CISCO(config-if-range)#switchport nonegotiate 
CISCO(config-if-range)#spanning-tree portfast
CISCO(config-if-range)#channel-group 3 mode active 

CISCO(config)#interface port-channel 3
CISCO(config-if)#description SYNOLOGY
CISCO(config-if)#switchport mode access
CISCO(config-if)#switchport nonegotiate

I will assign a description to both interfaces so I know what device is connected to these interfaces. The switchport mode is access and “nonegotiate” disables the negotiation for trunk / access mode. Portfast is enabled so we don’t have to wait for spanning-tree to unblock the port and I’m adding this interface to channel-group 3.

Once you assign the interfaces to the port-channel, you will see that the switch creates a new port-channel interface. I will also configure this interface for access mode and disable the negotiation for access/trunk switchport mode. After configuring the interfaces you will see the following on your console:

%LINK-3-UPDOWN: Interface Port-channel3, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel3, changed state to up

This means our port-channel is operational. To verify that both interfaces are working you can use the following command:

CISCO#show etherchannel 3 summary 
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port

Number of channel-groups in use: 3
Number of aggregators:           3

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
3      Po3(SU)         LACP      Gi0/37(P)   Gi0/38(P)

As you can see both interfaces are used (P=bundled) and the port-channel is in-use (U). I hope this has been helpful for you to get your Etherchannel working between the Synology NAS and your Cisco switch.

Tags: ,


Forum Replies

  1. Hi Bill,

    You are welcome, glad you like it. Hopefully you got it working!

    Rene

  2. Hi Rene,

    Do you know of any Cisco switch that supports IOS with 12 ports or less that I can get for this?

    Thanks!

  3. Hi Franklin,

    The 2960 and 3560 switches both have 8 port versions, those are nice for small labs.

    Rene

  4. You are welcome Shawn and thank you for your kind words!

3 more replies! Ask a question or join the discussion by visiting our Community Forum