Introduction to Redistribution

Most networks you encounter will probably only run a single routing protocol like OSPF or EIGRP. Maybe you find some old small networks that are still running RIP that need migration to OSPF or EIGRP. What if you have a company that is running OSPF and you just bought another company and their network is running EIGRP?

It’s possible that we have multiple routing protocols on our network and we’ll need some method to exchange routing information between the different protocols. This is called redistribution. We’ll look into some of the issues that we encounter. What are we going to do with our metrics? OSPF uses cost and EIGRP uses K-values and they are not compatible with each other….RIP uses hop count.

Redistribution also adds another problem. If you “import” routing information from one routing protocol into another it’s possible to create routing loops.

If you don’t feel 100% confident about your knowledge on OSPF and EIGRP then I suggest you stop reading now and read more about OSPF / EIGRP or do some labs. One routing protocol can be difficult but when you mix a couple of them the fun really starts…

Having said that, let’s take a look at a possible redistribution scenario:

redistribution 3 routing protocols

Look at the topology picture above. We have routers running EIGRP in AS 1 with the 10.0.0.0 /8 network. OSPF has multiple areas and we have 20.0.0.0 /8 there. At the bottom there are two RIP routers in the 30.0.0.0 /8 network. If we want to have full connectivity in this network we’ll have to do some redistribution.

Redistribution is not just for between routing protocols, we have multiple options:

  • Between routing protocols (RIP, OSPF, EIGRP, BGP).
  • Static routes can be redistributed into a routing protocol.
  • Directly connected routes can be redistributed into a routing protocol.

Normally you use the network command to advertise directly connected routes into your routing protocol. You can also use the redistribute connected command which will redistribute it into the routing protocol. Let’s take a look at some real routers:

redistribution eigrp rip

In the topology picture above I have three routers. R1 is running EIGRP and R3 is running RIP. R2 is in the middle and is running EIGRP and RIP. If we want to do redistribution we’ll have to do it on R2. Let’s take a look shall we?

R1(config)#router eigrp 12
R1(config-router)#no auto-summary
R1(config-router)#network 192.168.12.0     
R1(config-router)#network 1.1.1.0 0.0.0.255
R2(config)#router eigrp 12
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.12.0
R2(config-router)#exit
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no auto-summary 
R2(config-router)#network 192.168.23.0
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#no auto-summary 
R3(config-router)#network 192.168.23.0 
R3(config-router)#network 3.3.3.0

Here are the router configurations, nothing special…I only advertised the links to get EIGRP and RIP up and running.

R1#show ip route 

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
R2#show ip route    

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/156160] via 192.168.12.1, 00:05:01, FastEthernet0/0
R    3.0.0.0/8 [120/1] via 192.168.23.3, 00:00:12, FastEthernet1/0
C    192.168.23.0/24 is directly connected, FastEthernet1/0
R3#show ip route 

Gateway of last resort is not set

     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, Loopback0
C    192.168.23.0/24 is directly connected, FastEthernet0/0

Here are the routing table of all three routers after configuring RIP and EIGRP. You can see R2 has learned the loopback interfaces of R3 and R1. R1 and R3 don’t have anything in their routing table because R2 is not advertising anything. As you can see redistribution is not done automatically.

Before I show you the redistribution configurations there are two things you should be aware of:

We're Sorry, Full Content Access is for Members Only...

If you like to keep on reading, Become a Member Now! Here is why:

  • Learn any CCNA, CCNP and CCIE R&S Topic. Explained As Simple As Possible.
  • Try for Just $1. The Best Dollar You've Ever Spent on Your Cisco Career!
  • Full Access to our 654 Lessons. More Lessons Added Every Week!
  • Content created by Rene Molenaar (CCIE #41726)

535 Sign Ups in the last 30 days

satisfaction-guaranteed
100% Satisfaction Guaranteed!
You may cancel your monthly membership at any time.
No Questions Asked!

Tags: ,


Forum Replies

  1. Hey René,
    you missed something in the command syntax. After I have read your lesson, I tried the example. With the shown syntax John still doesn’t advertise the Loopback addresses and the connected network. You probably wrote it in the lesson, but I had to complete:

    John(config)#router eigrp 12
    John(config-router)#redistribute rip
    John(config-router)#redistribute connected
    
    John(config)#router rip
    John(config-router)#redistribute eigrp 12
    John(config-router)#redistribute connected
    

    With this syntax, John started to advertise the Loopback and his directly connec

    ... Continue reading in our forum

  2. Hi Sascha,

    That’s right, this tutorial is just an overview of redistribution but I didn’t show the full config. Here’s the configuration example for those 3 routers:

    ... Continue reading in our forum

  3. Hi Lazaros,
    When we do redistribution from Eigrp to OSPF vice versa, which exactly routes are advertised, the best routes in routing table it self OR all routes of EIGRP (or OSPF) before comparing the Admin Distance between different Protocols in routing table.?

  4. Lazaros,
    Many thanks for your usual support

  5. Hi Waleed,

    That would prevent routes from looping around but it also means you have a single point of failure. Redistribution on two routers is no problem but you have to understand and deal with potential issues. For example, take a look at route tagging:

    ... Continue reading in our forum

19 more replies! Ask a question or join the discussion by visiting our Community Forum